Certain json messages not found in elastic

I setup a dashboard in kibana and found the messages I was sending based on the 'type' field in the json that I specify. This is getting sent to a logstash index along millions of other types. I found certain msgTypes but not all and I know the json is being sent to elastic but tried every possible search to find it.
Is there someway to confirm that this message is in elastic besides through kibana discover. Eg:


 "pubDate":"2020-02-03 19:09:51",

I only the one with msgType:comment.

Hey @jdepp99, you can also use Console to query Elasticsearch directly, skipping Kibana.

One thing which might be tripping you up is the difference between the text and keyword field datatypes. The text fields go through analysis which "tokenizes" the strings, and searches will be executed against the individual tokens themselves. Where-as keyword fields don't go through analysis, so you'll be searching against the raw unprocessed text itself.

Thanks for responding. I will try the console. I did use both the text and keyword with no joy but lets see the console.

Still no result with the console. Do I need to delete the index perhaps?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.