Changing ES Scheme to http

Hi Community,

I am working on Arches project which uses Elasticsearch as its search engine.
In Arches Documentation, it is mentioned to add the following line to the settings.py in my project's directory:

ELASTICSEARCH_HOSTS = [{“scheme”: “http”, “host”: “localhost”, “port”: ELASTICSEARCH_HTTP_PORT}]

This overwrites the default ELASTICSEARCH_HOSTS variable, which has the scheme set to https.

However, I get the following error:

File "/root/ArchesProject/my_project1/my_project1/settings.py", line 366
    ELASTICSEARCH_HOSTS = [{“scheme”: “http”, “host”: “localhost”, “port”: ELASTICSEARCH_HTTP_PORT}]
                                   ^
SyntaxError: invalid character in identifier

Any idea on how to solve this issue?
Your help is much appreciated :slight_smile:

I don't know much about Arches but those double quotes look like they might be a special character that's not recognized. Can you copy and paste it as plain text in an editor and verify? You may want to retype it and try again.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.