Changing the refresh interval on running nodes

I am seeing the refresh interval of 5 seconds instead of 1 second that
I thought was the default. However, I want to change it to 1 second -
I was wondering if there is a way to do it without bringing any of the
nodes down. I have a cluster with 4 nodes and 1 index. Here is the
status from 1 of the 4 nodes:

os: {
refresh_interval: 5000
cpu: {
vendor: "Intel"
model: "Xeon"
mhz: 2266
total_cores: 2
total_sockets: 2
cores_per_socket: 16
cache_size: "8kb"
cache_size_in_bytes: 8192
}
mem: {
total: "3.9gb"
total_in_bytes: 4194304000
}
swap: {
total: "1.9gb"
total_in_bytes: 2097434624
}
}

Thanks - I appreciate your help!

-cheers,
Manish

Hi Manish

On Fri, 2011-06-03 at 10:59 -0700, Manish Pandit wrote:

I am seeing the refresh interval of 5 seconds instead of 1 second that
I thought was the default. However, I want to change it to 1 second -
I was wondering if there is a way to do it without bringing any of the
nodes down. I have a cluster with 4 nodes and 1 index. Here is the
status from 1 of the 4 nodes:

You can update the index settings:

http://www.elasticsearch.org/guide/reference/api/admin-indices-update-settings.html

clint

Thats the refresh interval for the os stats, not the index refresh interval :). If you get the settings for the index and you don't see any refresh interval setting, then its using the default.

On Friday, June 3, 2011 at 8:59 PM, Manish Pandit wrote:

I am seeing the refresh interval of 5 seconds instead of 1 second that
I thought was the default. However, I want to change it to 1 second -
I was wondering if there is a way to do it without bringing any of the
nodes down. I have a cluster with 4 nodes and 1 index. Here is the
status from 1 of the 4 nodes:

os: {
refresh_interval: 5000
cpu: {
vendor: "Intel"
model: "Xeon"
mhz: 2266
total_cores: 2
total_sockets: 2
cores_per_socket: 16
cache_size: "8kb"
cache_size_in_bytes: 8192
}
mem: {
total: "3.9gb"
total_in_bytes: 4194304000
}
swap: {
total: "1.9gb"
total_in_bytes: 2097434624
}
}

Thanks - I appreciate your help!

-cheers,
Manish

Where are the defaults listed?

I can't find them in the elasticsearch.yml file or on the admin indices updates settings doc page.

On Wed, Jul 3, 2013 at 4:55 PM, eranid eranid@gmail.com wrote:

Where are the defaults listed?

For refresh interval the defaults are here:
http://www.elasticsearch.org/guide/reference/index-modules/

Best regards,
Radu

http://sematext.com/ -- ElasticSearch -- Solr -- Lucene

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Awesome! Thanks Radu!

which should help my io-waits if it is due to lots of (re)indexing? refresh_interval or index.translog.flush_threshold fields?

Incidentally, do you happen to know where I can find index.translog defaults?

On Wed, Jul 3, 2013 at 5:50 PM, eranid eranid@gmail.com wrote:

Awesome! Thanks Radu!

You're welcome :slight_smile:

which should help my io-waits if it is due to lots of (re)indexing?
refresh_interval or index.translog.flush_threshold fields?

I would assume the translog settings, but merge settings have a lot more to
do with that. You can limit the impact of merging via store
throttlinghttp://www.elasticsearch.org/guide/reference/index-modules/store/,
which will make your merges take longer, but with less load.

However, in my experience, increasing refresh_interval had the biggest
impact on indexing performance (after using the bulk
apihttp://www.elasticsearch.org/guide/reference/api/bulk/).
So I guess there's no getting away from benchmarking and monitoring to see
what fits you best.

Incidentally, do you happen to know where I can find index.translog
defaults?

Yes, it's in the translog settings page:
http://www.elasticsearch.org/guide/reference/index-modules/translog/

Best regards,
Radu

http://sematext.com/ -- ElasticSearch -- Solr -- Lucene

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.