Index.refresh_interval setting in elasticsearch.yml not taking effect


(T Vinod Gupta) #1

does this look wrong?

elasticsearch.yml:
index.refresh_interval: 60s

after i restart ES, it doesnt look like taking effect -
curl -XGET 'http://localhost:9200/_cluster/nodes?pretty=true'
...
"os" : {
"refresh_interval" : 1000,
"cpu" : {
....
"process" : {
"refresh_interval" : 1000,

thanks


(Igor Motov) #2

These are two different settings. The setting that you set in the config
file determines how often shards should be automatically refreshed, the
value that you check by running your request shows how often os stats
should be updated.

On Sunday, July 8, 2012 12:14:49 PM UTC-4, T Vinod Gupta wrote:

does this look wrong?

elasticsearch.yml:
index.refresh_interval: 60s

after i restart ES, it doesnt look like taking effect -
curl -XGET 'http://localhost:9200/_cluster/nodes?pretty=true'
...
"os" : {
"refresh_interval" : 1000,
"cpu" : {
....
"process" : {
"refresh_interval" : 1000,

thanks


(T Vinod Gupta) #3

That's what I guessed too. But then /_settings was also not showing this. Then did a post to _settings for refresh_interval. That seemed to reflect in the get call. But then I don't know if this will persist after restart.

Thanks

Sent from my iPhone

On Jul 8, 2012, at 10:38 AM, Igor Motov imotov@gmail.com wrote:

These are two different settings. The setting that you set in the config file determines how often shards should be automatically refreshed, the value that you check by running your request shows how often os stats should be updated.

On Sunday, July 8, 2012 12:14:49 PM UTC-4, T Vinod Gupta wrote:
does this look wrong?

elasticsearch.yml:
index.refresh_interval: 60s

after i restart ES, it doesnt look like taking effect -
curl -XGET 'http://localhost:9200/_cluster/nodes?pretty=true'
...
"os" : {
"refresh_interval" : 1000,
"cpu" : {
....
"process" : {
"refresh_interval" : 1000,

thanks


(Radu Gheorghe) #4

It does persist after restart.

I think the configuration option you initially wrote will work just fine,
but I don't know of a way to verify that with the REST API.

I usually change this in a general way by defining an index template in my
configuration. Take a look here for details:
http://www.elasticsearch.org/guide/reference/api/admin-indices-templates.html

On Sunday, July 8, 2012 8:56:22 PM UTC+3, T Vinod Gupta wrote:

That's what I guessed too. But then /_settings was also not showing this.
Then did a post to _settings for refresh_interval. That seemed to reflect
in the get call. But then I don't know if this will persist after restart.

Thanks

Sent from my iPhone

On Jul 8, 2012, at 10:38 AM, Igor Motov <> wrote:

These are two different settings. The setting that you set in the config
file determines how often shards should be automatically refreshed, the
value that you check by running your request shows how often os stats
should be updated.

On Sunday, July 8, 2012 12:14:49 PM UTC-4, T Vinod Gupta wrote:

does this look wrong?

elasticsearch.yml:
index.refresh_interval: 60s

after i restart ES, it doesnt look like taking effect -
curl -XGET 'http://localhost:9200/_cluster/nodes?pretty=true'
...
"os" : {
"refresh_interval" : 1000,
"cpu" : {
....
"process" : {
"refresh_interval" : 1000,

thanks


(T Vinod Gupta) #5

Thanks, I did see it getting persisted after restart.

You also asked me to check out bigdesk. I was finally able to do so.. So
what are the typical things that should alarm me? somethings that stand out
in my case -

  1. open transport channels = 231. seems high
  2. threads count = 85-105 range.. seems high. peak = 125
  3. fields cache size = 168mb, filter cache size = 37mb. doesnt look bad.

thanks

On Sun, Jul 8, 2012 at 11:26 PM, Radu Gheorghe radu0gheorghe@gmail.comwrote:

It does persist after restart.

I think the configuration option you initially wrote will work just fine,
but I don't know of a way to verify that with the REST API.

I usually change this in a general way by defining an index template in my
configuration. Take a look here for details:

http://www.elasticsearch.org/guide/reference/api/admin-indices-templates.html

On Sunday, July 8, 2012 8:56:22 PM UTC+3, T Vinod Gupta wrote:

That's what I guessed too. But then /_settings was also not showing this.
Then did a post to _settings for refresh_interval. That seemed to reflect
in the get call. But then I don't know if this will persist after restart.

Thanks

Sent from my iPhone

On Jul 8, 2012, at 10:38 AM, Igor Motov <> wrote:

These are two different settings. The setting that you set in the config
file determines how often shards should be automatically refreshed, the
value that you check by running your request shows how often os stats
should be updated.

On Sunday, July 8, 2012 12:14:49 PM UTC-4, T Vinod Gupta wrote:

does this look wrong?

elasticsearch.yml:
index.refresh_interval: 60s

after i restart ES, it doesnt look like taking effect -
curl -XGET 'http://localhost:9200/_**cluster/nodes?pretty=truehttp://localhost:9200/_cluster/nodes?pretty=true
'
...
"os" : {
"refresh_interval" : 1000,
"cpu" : {
....
"process" : {
"refresh_interval" : 1000,

thanks


(Radu Gheorghe) #6

I don't know, I would have guessed that if you have spikes in your query
times you would see the same spikes in BigDesk somewhere...

Isn't that the case?

luni, 9 iulie 2012, 09:33:54 UTC+3, T Vinod Gupta a scris:

Thanks, I did see it getting persisted after restart.

You also asked me to check out bigdesk. I was finally able to do so.. So
what are the typical things that should alarm me? somethings that stand out
in my case -

  1. open transport channels = 231. seems high
  2. threads count = 85-105 range.. seems high. peak = 125
  3. fields cache size = 168mb, filter cache size = 37mb. doesnt look bad.

thanks

On Sun, Jul 8, 2012 at 11:26 PM, Radu Gheorghe <> wrote:

It does persist after restart.

I think the configuration option you initially wrote will work just fine,
but I don't know of a way to verify that with the REST API.

I usually change this in a general way by defining an index template in
my configuration. Take a look here for details:

http://www.elasticsearch.org/guide/reference/api/admin-indices-templates.html

On Sunday, July 8, 2012 8:56:22 PM UTC+3, T Vinod Gupta wrote:

That's what I guessed too. But then /_settings was also not showing
this. Then did a post to _settings for refresh_interval. That seemed to
reflect in the get call. But then I don't know if this will persist after
restart.

Thanks

Sent from my iPhone

On Jul 8, 2012, at 10:38 AM, Igor Motov <> wrote:

These are two different settings. The setting that you set in the config
file determines how often shards should be automatically refreshed, the
value that you check by running your request shows how often os stats
should be updated.

On Sunday, July 8, 2012 12:14:49 PM UTC-4, T Vinod Gupta wrote:

does this look wrong?

elasticsearch.yml:
index.refresh_interval: 60s

after i restart ES, it doesnt look like taking effect -
curl -XGET 'http://localhost:9200/_**cluster/nodes?pretty=truehttp://localhost:9200/_cluster/nodes?pretty=true
'
...
"os" : {
"refresh_interval" : 1000,
"cpu" : {
....
"process" : {
"refresh_interval" : 1000,

thanks


(system) #7