Elastic search ignoring refresh_interval setting from elasticsearch.yml


(Arjit Gupta) #1

Hi,

We have made an entry in elasticsearch.yml for refresh_interval as
index.refresh_interval: 1s

But its not honouring the setting .

When I get setting to cluster to it.

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
}
}
}

But when make a rest call

curl -XPUT 'http://localhost:9200/*/_settings' -d '{"index" :
{"refresh_interval" : "1s"}}'

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
"index.refresh_interval" : "1s"
}
}
}

Thanks,
Arjit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Arjit Gupta) #2

Any one ?

Thanks ,
Arjit

On Fri, Jul 19, 2013 at 3:53 PM, Arjit Gupta arjit292@gmail.com wrote:

Hi,

We have made an entry in elasticsearch.yml for refresh_interval as
index.refresh_interval: 1s

But its not honouring the setting .

When I get setting to cluster to it.

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
}
}
}

But when make a rest call

curl -XPUT 'http://localhost:9200/*/_settings' -d '{"index" :
{"refresh_interval" : "1s"}}'

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
"index.refresh_interval" : "1s"
}
}
}

Thanks,
Arjit

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/APbMvt9WFK4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brian Yoder) #3

I may be wrong, but I'll hazard an educated guess...

Your configuration specifies the default index refresh interval for all
indices. When your second GET request is issued, you see the defaults that
you have explicitly configured.

When you query the specific index, you see only the explicitly configured
settings for that specific index, but not the values that were configured
for all indices. In other words, perhaps ES is not showing the inherited
settings when querying a specific index's settings.

It does look confusing, and it does seem like a minor bug (perhaps).

But I would guess that ES is honoring the setting, regardless of whether or
not it displays that setting. Just as it honors all of the built-in default
settings that it doesn't display in all cases. At least, that's been my
empirically determined views.

Brian

On Friday, July 19, 2013 6:23:44 AM UTC-4, Arjit Gupta wrote:

Hi,

We have made an entry in elasticsearch.yml for refresh_interval as
index.refresh_interval: 1s

But its not honouring the setting .

When I get setting to cluster to it.

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
}
}
}

But when make a rest call

curl -XPUT 'http://localhost:9200/*/_settings' -d '{"index" :
{"refresh_interval" : "1s"}}'

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
"index.refresh_interval" : "1s"
}
}
}

Thanks,
Arjit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Arjit Gupta) #4

I am guessing ES is not honoring the setting because the index response
time are very bad before I set index.referesh_interval to 1 and they
improve when the update the setting to 1s.
I was confused thinking I might be entering the setting at the wrong place
in configration file.

Please correct me if i am wrong.

Thanks ,
Arjit

On Sun, Jul 21, 2013 at 1:40 AM, InquiringMind brian.from.fl@gmail.comwrote:

I may be wrong, but I'll hazard an educated guess...

Your configuration specifies the default index refresh interval for all
indices. When your second GET request is issued, you see the defaults that
you have explicitly configured.

When you query the specific index, you see only the explicitly configured
settings for that specific index, but not the values that were configured
for all indices. In other words, perhaps ES is not showing the inherited
settings when querying a specific index's settings.

It does look confusing, and it does seem like a minor bug (perhaps).

But I would guess that ES is honoring the setting, regardless of whether
or not it displays that setting. Just as it honors all of the built-in
default settings that it doesn't display in all cases. At least, that's
been my empirically determined views.

Brian

On Friday, July 19, 2013 6:23:44 AM UTC-4, Arjit Gupta wrote:

Hi,

We have made an entry in elasticsearch.yml for refresh_interval as
index.refresh_interval: 1s

But its not honouring the setting .

When I get setting to cluster to it.

curl -XGET 'http://localhost:9200/test/**settings?pretty=truehttp://localhost:9200/test/_settings?pretty=true
'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my
**analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_**analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
}
}
}

But when make a rest call

curl -XPUT 'http://localhost:9200/*/_**settingshttp://localhost:9200/*/_settings'
-d '{"index" : {"refresh_interval" : "1s"}}'

curl -XGET 'http://localhost:9200/test/**settings?pretty=truehttp://localhost:9200/test/_settings?pretty=true
'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my
**analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_**analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
"index.refresh_interval" : "1s"
}
}
}

Thanks,
Arjit

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/APbMvt9WFK4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brian Yoder) #5

The default setting for index refresh interval is 1s.

If you experienced bad response times, my guess is a heavy bulk load
happened at the same time as requests. In this case, I set the refresh
interval to 2m (2 minutes) per some recommendation I read, and then set it
back to 1s when the bulk load is done.

For normal (low volume) updates, I leave the index refresh interval alone
(it is therefore 1s) and my updates are quick and resulting queries see
them on the local box without noticeable delay.

But this is only my experience as a user of ES, and not that of a developer
of ES.

Brian

On Sunday, July 21, 2013 10:36:32 PM UTC-4, Arjit Gupta wrote:

I am guessing ES is not honoring the setting because the index response
time are very bad before I set index.referesh_interval to 1 and they
improve when the update the setting to 1s.
I was confused thinking I might be entering the setting at the wrong place
in configration file.

Please correct me if i am wrong.

Thanks ,
Arjit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Kartavya) #6

You can check your such global configurations here

curl -XGET 'localhost:9200/_nodes?pretty=true

Thanks,
Pulkit

On Friday, 19 July 2013 10:23:44 UTC, Arjit Gupta wrote:

Hi,

We have made an entry in elasticsearch.yml for refresh_interval as
index.refresh_interval: 1s

But its not honouring the setting .

When I get setting to cluster to it.

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
}
}
}

But when make a rest call

curl -XPUT 'http://localhost:9200/*/_settings' -d '{"index" :
{"refresh_interval" : "1s"}}'

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
"index.refresh_interval" : "1s"
}
}
}

Thanks,
Arjit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/31fbd73e-9859-4b79-9bd4-c8a0e289955b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Clinton Gormley) #7

Hi Arjit

When you set it via the config file, it isn't included in the output of GET
/_settings, but is is being honoured.

That said, I much prefer using the API for these things instead of setting
them in the config file

clint

On 24 April 2014 14:27, Kartavya pulkitdotcom@gmail.com wrote:

You can check your such global configurations here

curl -XGET 'localhost:9200/_nodes?pretty=true

Thanks,
Pulkit

On Friday, 19 July 2013 10:23:44 UTC, Arjit Gupta wrote:

Hi,

We have made an entry in elasticsearch.yml for refresh_interval as
index.refresh_interval: 1s

But its not honouring the setting .

When I get setting to cluster to it.

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
}
}
}

But when make a rest call

curl -XPUT 'http://localhost:9200/*/_settings' -d '{"index" :
{"refresh_interval" : "1s"}}'

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
"index.refresh_interval" : "1s"
}
}
}

Thanks,
Arjit

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/31fbd73e-9859-4b79-9bd4-c8a0e289955b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/31fbd73e-9859-4b79-9bd4-c8a0e289955b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAPt3XKSs-hWsmAQdBnkYkjAC6jWKmBGt-mgcoBVMj%2Bo%3DANft-g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Arjit Gupta) #8

Thanks a lot clint for the clarity on this .

Thanks ,
Arjit

On Thu, Apr 24, 2014 at 6:25 PM, Clinton Gormley clint@traveljury.comwrote:

Hi Arjit

When you set it via the config file, it isn't included in the output of
GET /_settings, but is is being honoured.

That said, I much prefer using the API for these things instead of setting
them in the config file

clint

On 24 April 2014 14:27, Kartavya pulkitdotcom@gmail.com wrote:

You can check your such global configurations here

curl -XGET 'localhost:9200/_nodes?pretty=true

Thanks,
Pulkit

On Friday, 19 July 2013 10:23:44 UTC, Arjit Gupta wrote:

Hi,

We have made an entry in elasticsearch.yml for refresh_interval as
index.refresh_interval: 1s

But its not honouring the setting .

When I get setting to cluster to it.

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
}
}
}

But when make a rest call

curl -XPUT 'http://localhost:9200/*/_settings' -d '{"index" :
{"refresh_interval" : "1s"}}'

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.analysis.analyzer.my_analyzer.tokenizer" : "keyword",
"index.analysis.analyzer.my_analyzer.filter" : "lowercase",
"index.number_of_shards" : "5",
"index.number_of_replicas" : "2",
"index.version.created" : "900199",
"index.refresh_interval" : "1s"
}
}
}

Thanks,
Arjit

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/31fbd73e-9859-4b79-9bd4-c8a0e289955b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/31fbd73e-9859-4b79-9bd4-c8a0e289955b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/APbMvt9WFK4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAPt3XKSs-hWsmAQdBnkYkjAC6jWKmBGt-mgcoBVMj%2Bo%3DANft-g%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAPt3XKSs-hWsmAQdBnkYkjAC6jWKmBGt-mgcoBVMj%2Bo%3DANft-g%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CADe%2BHd_K%2BNLRTsuQM%3D0zeH%3D5DH%3D5wr8Up_SLvr%3Dxr%3D2P1LomBQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #9