ClassNotFoundException using kuromoji analyzer


(slushi) #1

I am using version 0.90.3 with kuromoji 1.5. After install, I can't seem to
use the analyzer. I run:

curl -XPUT 'http://localhost:9200/k/' -d '{
"analysis" : {
"analyzer" : {
"_kuromoji" : {
"type" : "kuromoji"
}
}
}
}'

but get an error:
{
"error": "IndexCreationException[[k] failed to create index]; nested:
ElasticSearchIllegalArgumentException[failed to find analyzer type
[kuromoji] or tokenizer for [_kuromoji]]; nested:
NoClassSettingsException[Failed to load class setting [type] with value
[kuromoji]]; nested:
ClassNotFoundException[org.elasticsearch.index.analysis.kuromoji.KuromojiAnalyzerProvider];
",
"status": 400
}

The class name seems wrong in the error message. The kuromoji package
doesn't seem to exist in the repo. I get the same error for the
smart_chinese plugin. Has anyone got these to work?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(slushi) #2

never mind, restarting the node did the trick

On Monday, October 14, 2013 5:39:17 PM UTC-4, slushi wrote:

I am using version 0.90.3 with kuromoji 1.5. After install, I can't seem
to use the analyzer. I run:

curl -XPUT 'http://localhost:9200/k/' -d '{
"analysis" : {
"analyzer" : {
"_kuromoji" : {
"type" : "kuromoji"
}
}
}
}'

but get an error:
{
"error": "IndexCreationException[[k] failed to create index]; nested:
ElasticSearchIllegalArgumentException[failed to find analyzer type
[kuromoji] or tokenizer for [_kuromoji]]; nested:
NoClassSettingsException[Failed to load class setting [type] with value
[kuromoji]]; nested:
ClassNotFoundException[org.elasticsearch.index.analysis.kuromoji.KuromojiAnalyzerProvider];
",
"status": 400
}

The class name seems wrong in the error message. The kuromoji package
doesn't seem to exist in the repo. I get the same error for the
smart_chinese plugin. Has anyone got these to work?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3