Cluster cannot find the other node


(Arvid De Jong) #1

Hey!

So i'm trying to setup a cluster with 2 nodes in total. I uncommented the cluster.name: my-application on both nodes (i didn't change the cluster name, it's just for testing).

I've also uncommented the node.name. I tried it with unicast and multicast, both aren't working.

I read that i only have to change to cluster name and than the auto discovery completes the job, but it isn't and i have no idea why.

Thanks in advance!

Greetings,

Arvid


(David Pilato) #2

1.x ? 2.x ?


(Arvid De Jong) #3

Hi,

I use Elasticsearch 2.1.0. The only two things i have uncommented are in the elasticsearch.yml file are:

cluster.name: my-application

node.name: node-1

and for node 2 the name is node-2.

Greetings,

Arvid


(David Pilato) #4

Change network.host and set the unicast list of hosts.


(Arvid De Jong) #5

Thanks, but unfortunately it is still not working:(

So this is what I changed now in the config file:

Node 1
network.host: 172.16.206.10

discovery.zen.ping.unicast.hosts: ["172.16.206.11"]

Node 2
network.host: 172.16.206.11

discovery.zen.ping.unicast.hosts: ["172.16.206.10"]

After i added these changes it is says the following when i try to use curl -XGET 'http://localhost:9200/_cat/health?v':

curl: (7) couldn't connect to host

Greetings,

Arvid


(Arvid De Jong) #6

Aaah! It's working now!:slight_smile: I changed the command to curl '172.16.206.10:9200/_cat/health?v' instead of using the localhost. I can see 2 nodes now.

Thank you very much!


(system) #7