Elasticsearch nodes on same machine unable to find each other


#1

I'm working with big machines so I have decided to run multiple nodes on each server. Before uncommenting network.host and discovery.zen.ping.unicast.hosts I could boot the cluster and the two nodes would connect. However after adding the hostname(which is the same for both) and the IP with the ports they should run on they no longer connect and instead each form their own cluster. I have tried switching the IP with the hostname as well as starting one and letting it compeley start before starting the second. No matter what I do I cannot get them to connect when network.host is configured. Sorry for having to remove some of the info. If you need any more info please let me know.

Edit: When I curl for /_cat/nodes for each server they both return a cluster of one

Node 1 & 2 output: https://pastebin.com/h7Lx22JP


(Mark Walkom) #2

Please post the settings you changed.


#3

I changed max_local_storage_nodes to 2 as well as the changes above. Below is a link to my elasticsearch.yml. Is there anything else I can provide that would give you insight?

https://pastebin.com/VsPByz3L

Update: I've manually set the network.host for both nodes to an IP address and added discovery.zen.minimum_master_nodes: 2. The issue still continues. Both nodes endlessly ping but never find each other. I then added node.master=true and node.data=false to the first node and node.master=true and node.data=true to the second. After this they continue to endlessly ping only finding 1(themselves) out of the 2 needed to form a cluster.


#4

New info. I moved one node to another machine with all default settings other than network.host and they still cannot find one another. I tried to telnet from the first server to the second server (including the second node's port) and it seems no response is given and it just stays on "Escape character is '^]'"

Edit:
So I should have mentioned that I have 6 machines and currently there are 6 nodes on each of an elastic 2.4 cluster. I tried adding one and it works. I looked in the config and there is nothing unusual except for a plugin called searchguard. Did the discovery method change between versions? I see on the 2.4 cluster has multicast disabled and it is no longer in 5.4 so I don't think that difference could cause this issue.

Edit 2: Also I can access both nodes (by hostname:port & IP:port) through my web browser which is on a different computer on the same network.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.