Cluster set up on ec2


(Y Lin) #1

About 98 machines returned in discovery nodes list. Most of them don't have
ES installed.

I tried to use groups to filter, but it doesn't work.

Here is my setting:
discovery:
type: ec2
ec2:
ping_timeout: 5s
groups: sgn2-stg-sss
any_group: false

I'm sure only 3 machines within the group. What should I do to filter out?

Thanks a lot

--


(andreas.chatzakis) #2

It might be an issue with your config file syntax (Indentation is important
in yml syntax)
I would add a space before the groups field:

discovery:
type: ec2
ec2:
groups: sgn2-stg-sss

or make it explicit with:

discovery.ec2.groups: sgn2-stg-sss

If that fails can you share part of your logs?
/usr/local/elasticsearch/logs/elasticsearch.log

Andreas

On Tuesday, August 28, 2012 6:44:00 AM UTC+3, Y Lin wrote:

About 98 machines returned in discovery nodes list. Most of them don't
have ES installed.

I tried to use groups to filter, but it doesn't work.

Here is my setting:
discovery:
type: ec2
ec2:
ping_timeout: 5s
groups: sgn2-stg-sss
any_group: false

I'm sure only 3 machines within the group. What should I do to filter out?

Thanks a lot

--


(max) #3

Hi,

we had at the beginning quite some troubles getting this right, maybe this
helps you:
we are using this settings for our ec2 cluster:

discovery.type: ec2

don't know if important for you, but when you are not in one of the us
standard regions you should use something like this:
cloud.aws.region: eu-west-1

I still don't know if it uses the name of the group or the group id, so we
put in both and this works, just make sure that all of the machines in your
cluster are in this group and that the AWS-account that you are using has
the right to query the groups & machines :slight_smile:
discovery.ecs.groups: sg-XXXXXX,
*
*
In your example the securitygroup has two "-" in it, are you sure this is
the right one?

*discovery.ec2.any_group: false
*

and one of the most important settings was:
discovery.zen.ping.timeout: 5m
5 minutes is quite long, i know, but just to be save... we had big problems
if shorter than 30 seconds, so we went the secure path :slight_smile:

hope some of this may helps helped you, the logfile just gives you also
good information where the problem could be.
Max

Am Dienstag, 28. August 2012 10:25:29 UTC+2 schrieb andreas.chatzakis:

It might be an issue with your config file syntax (Indentation is
important in yml syntax)
I would add a space before the groups field:

discovery:
type: ec2
ec2:
groups: sgn2-stg-sss

or make it explicit with:

discovery.ec2.groups: sgn2-stg-sss

If that fails can you share part of your logs?
/usr/local/elasticsearch/logs/elasticsearch.log

Andreas

On Tuesday, August 28, 2012 6:44:00 AM UTC+3, Y Lin wrote:

About 98 machines returned in discovery nodes list. Most of them don't
have ES installed.

I tried to use groups to filter, but it doesn't work.

Here is my setting:
discovery:
type: ec2
ec2:
ping_timeout: 5s
groups: sgn2-stg-sss
any_group: false

I'm sure only 3 machines within the group. What should I do to filter out?

Thanks a lot

--


(system) #4