Cluster setting in elasticsearch http output


(Will) #1

[Please move to logstash forum; sorry]

https://www.elastic.co/guide/en/logstash/2.0/breaking-changes.html#_configuration_changes
says:
The Elasticsearch output plugin configuration has the following changes:
[...]
New options: bind_host, bind_port, cluster, embedded, embedded_http_port, port, sniffing_delay

This doesn't make sense, since 'cluster' was an option before, not sure why it's listed as a new option, especially since I get this error with logstash 2.0.0:
/opt/logstash/bin/logstash --configtest -f /etc/logstash/conf.d/99_output.conf
Unknown setting 'cluster' for elasticsearch {:level=>:error}

In my config, I am using the http elasticsearch transport with:

  elasticsearch {
    cluster => "logs"
    hosts => ["foo:9200"]```

In any event, is there a supported way to configure what cluster to talk to, or is there simply only one possible cluster when using HTTP?

I don't see the options listed as "new" (except for sniffing_delay) above at:
https://www.elastic.co/guide/en/logstash/current/plugins-outputs-elasticsearch.html
so is it possible that they meant "obsolete" rather than "new"?

(Magnus B├Ąck) #2

This doesn't make sense, since 'cluster' was an option before, not sure why it's listed as a new option, [...]

Indeed, that's incorrect. embedded and embedded_port were also removed so the list appears to be a mix of additions and deletions.

In any event, is there a supported way to configure what cluster to talk to, or is there simply only one possible cluster when using HTTP?

The latter. The host:port tuple you supply identifies the cluster. The HTTP API has no cluster parameter.


(David F.) #3

I've the same problem.


(system) #4