Cluster state RED when restoring the snapshot


#1

Hello,

I am using snapshot api to create and restore my index to s3. Everything is fine while creating snapshot to s3.
But the problem arises when I restore the snapshot with two methods.

Firstly I tried to restore the snapshot directly to a different cluster. The index was RED and hence cluster was RED.
Secondly, I ran the mapping for the index and then closed the index, with the same settings as of the index i created snapshot with. Now, I restored the index. During this process, the index went RED and OPEN, due to which the cluster was RED.

How can I avoid cluster to be RED?

Updates: This seems to be issue only when the snapshot is created with server_side_encryption enabled.


(Igor Motov) #2

During restore process we create an index first, but until restore is complete this index is not available for searching and indexing. Therefore it is marked as RED, making entire cluster RED. This is expected and you cannot avoid it.

I am really not sure how encryption would change that, so this update is really puzzling.


#3

Yes, the document specifies the same behavior of the cluster being red until restore is complete. In Second Process, the cluster was RED only when I had created the snapshot with server_side_encryption enabled.
If I don't use any encryption while creating the snapshot then, and following the same steps as in Second process, the cluster doesn't go into RED state.

This is very confusing but. I replicated the behavior thrice to verify.


(Ali Beyad) #4

Can you please provide the exact steps to replicate the problem (including where setting server_side_encryption is set to false and the cluster isn't RED), including all the JSON configuration you provided in each step?

Also, what version of Elasticsearch are you running?


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.