clusterHealthCheckParams failing in readiness probe on startup

I am trying to deploy elasticsearch with xpack security enabled but when i use the official helm charts, i get an error with "wait for status green". I have tried a "wait for status yellow" and get the same error and I have also tried "local=true" to see whether that gets rid of the error but that doesn't work either.

Does anyone have any ideas what the problems might be?

Secondly, at the top of the values.yaml file, there are 3 settings

clusterName: "enerlytics-ops"
nodeGroup: "elasticsearch"

The service that non master groups will try to connect to when joining the cluster
This should be set to clusterName + "-" + nodeGroup for your master group
masterService: "enerlytics-ops-elasticsearch"

If these are incorrect, could they be linked to the problem - however, if I have xpack security disabled it all seems to work OK. What might the problem be?

is clusterName the name of the full K8s cluster that I am installing elasticsearch on as it isn't on its own cluster, it is part of a bigger cluster.

Any help would be greatly appreciated to an elasticsearch novice...

Many thanks


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.