Color ranges broken in Metricbeat visualizations


(Joshua Iverson) #1

Some of the Kibana visualizations for Metricbeats appear to have a typo that prevent the color ranges from rendering properly. Basically the word "operator" is spelled "opperator" in the .json files that generate the visualizations. I can open an issue and submit a PR if someone agrees this is an issue.

For example, see:


(Mario Castro) #2

Hi @patentibus :slight_smile:

Thank you for your message. It's true that it seems awkward and I have checked that we also have the term opperator in the haproxy and system dashboard so I'm not sure if this is intentional.

I have tried to rebuild the dashboard with the typo corrected but I haven't seen any color range in any of the bar charts (as I was expecting)

I'll move this to the Kibana board to see if they can help with this issue


(Joshua Iverson) #3

Thank you for taking a look, @Mario_Castro. If you use the visualization editor in Kibana and look at the panel options for the visualizations that use "opperator", you'll see that the dropdowns are blank, if you change "opperator" to "operator" and reload them, I believe they will say ">= greater than or equal". Screenshots attached below.



(Mario Castro) #4

Now I can see the issue. I was looking in a bar chart instead of the gauge. Now I'm able to reproduce.

Can you file a new issue in Github referencing this discuss conversation? Of course you are more than welcome to help fixing it :slight_smile:

Thanks for the heads up


(Joshua Iverson) #5

Issue: https://github.com/elastic/beats/issues/8633
PR: https://github.com/elastic/beats/pull/8634


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.