[Completion] Max Lengh For Single Input Works Wrong


(Sang Dang) #1

Hi,
I read the document and see that the default is 50.
I have tried to input too long to check:
like that:

curl -X PUT 'localhost:9200/music/song/2?refresh=true' -d '{

"name" : "Nevermind",

"suggest" : {

    "input": [ "Nevermind XYZ","When an existing mapping already exists 

under the given type, the two mapping definitions, the one already defined,
and the new ones are merged. The ignore_conflicts parameters can be used to
control if conflicts should be ignored or not, by default, it is set
to false which means conflicts are not ignored." ],

    "output": "Nirvana - Nevermind X 2",

    "payload" : { "artistId" : 2321 },

    "weight" : 34

}

}'

It give me successful.
I have tried to test suggest:

curl -X POST 'localhost:9200/music/_suggest?pretty' -d '{

"song2-suggest" : {

    "text" : "When an existing mapping already exists under the given 

type, the two mapping definitions, the one already defined, and the new
ones are merged",

    "completion" : {

        "field" : "suggest"

    }

}

}'

Then it show me the result -> still work although the text lengh is over 50.

So it mean the "max_input_len" value is not work as expected right ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2