Compressing http responses


(oscarfh2) #1

Hi,
Elasticsearch si being used in my project and I am learning it now.
Currently we have a query that generates a large response and we would like
to compress the http response. To do so I added a key:
http.compression: true
in my elasticsearch.yml

If I make the query on Firefox (be acessing localhost:9200/test/_search) I
do not get the Content-Encoding:gzip as I do on other websites.
The size (8kb) also doesn't change.

Is there anything else I have to do to compress the response?

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/21fbf526-599a-4bbb-8b0f-7a4fb583ec94%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

It works here

Setting:

http:
host: 127.0.0.1
compression: true

Response headers:

Content-Encoding: gzip
Content-Length: 225
Content-Type: application/json; charset=UTF-8

200 OK

Jörg

On Tue, Jul 22, 2014 at 3:09 PM, oscarfh2 oscarfh@gmail.com wrote:

Hi,
Elasticsearch si being used in my project and I am learning it now.
Currently we have a query that generates a large response and we would
like to compress the http response. To do so I added a key:
http.compression: true
in my elasticsearch.yml

If I make the query on Firefox (be acessing localhost:9200/test/_search) I
do not get the Content-Encoding:gzip as I do on other websites.
The size (8kb) also doesn't change.

Is there anything else I have to do to compress the response?

Thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/21fbf526-599a-4bbb-8b0f-7a4fb583ec94%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/21fbf526-599a-4bbb-8b0f-7a4fb583ec94%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHL-m8A-yvONV6%2B3cRi-6gvdhb01RvxPU%2BHGejkS5XAGQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(oscarfh2) #3

I really can't make it work :frowning:
My elasticsearch is fronted by an Apache server, in which I am also trying
to compress the data, but for some reason I can't reduce the size of the
output.

2014-07-22 12:21 GMT-03:00 joergprante@gmail.com joergprante@gmail.com:

It works here

Setting:

http:
host: 127.0.0.1
compression: true

Response headers:

Content-Encoding: gzip
Content-Length: 225
Content-Type: application/json; charset=UTF-8

200 OK

Jörg

On Tue, Jul 22, 2014 at 3:09 PM, oscarfh2 oscarfh@gmail.com wrote:

Hi,
Elasticsearch si being used in my project and I am learning it now.
Currently we have a query that generates a large response and we would
like to compress the http response. To do so I added a key:
http.compression: true
in my elasticsearch.yml

If I make the query on Firefox (be acessing localhost:9200/test/_search)
I do not get the Content-Encoding:gzip as I do on other websites.
The size (8kb) also doesn't change.

Is there anything else I have to do to compress the response?

Thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/21fbf526-599a-4bbb-8b0f-7a4fb583ec94%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/21fbf526-599a-4bbb-8b0f-7a4fb583ec94%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/KtwnOX1rDeM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHL-m8A-yvONV6%2B3cRi-6gvdhb01RvxPU%2BHGejkS5XAGQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHL-m8A-yvONV6%2B3cRi-6gvdhb01RvxPU%2BHGejkS5XAGQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAFUsEtC7gt%3DK72C%2BjTcZJqbCEzao2CbkC8z%2BtX%2Bd_rxz-Fv9MQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #4

Not related to ES, but maybe you know about this help page?

https://wiki.apache.org/httpd/ReInflating

Jörg

On Tue, Jul 22, 2014 at 6:25 PM, Oscar oscarfh@gmail.com wrote:

I really can't make it work :frowning:
My elasticsearch is fronted by an Apache server, in which I am also trying
to compress the data, but for some reason I can't reduce the size of the
output.

2014-07-22 12:21 GMT-03:00 joergprante@gmail.com joergprante@gmail.com:

It works here

Setting:

http:
host: 127.0.0.1
compression: true

Response headers:

Content-Encoding: gzip
Content-Length: 225
Content-Type: application/json; charset=UTF-8

200 OK

Jörg

On Tue, Jul 22, 2014 at 3:09 PM, oscarfh2 oscarfh@gmail.com wrote:

Hi,
Elasticsearch si being used in my project and I am learning it now.
Currently we have a query that generates a large response and we would
like to compress the http response. To do so I added a key:
http.compression: true
in my elasticsearch.yml

If I make the query on Firefox (be acessing localhost:9200/test/_search)
I do not get the Content-Encoding:gzip as I do on other websites.
The size (8kb) also doesn't change.

Is there anything else I have to do to compress the response?

Thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/21fbf526-599a-4bbb-8b0f-7a4fb583ec94%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/21fbf526-599a-4bbb-8b0f-7a4fb583ec94%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/KtwnOX1rDeM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHL-m8A-yvONV6%2B3cRi-6gvdhb01RvxPU%2BHGejkS5XAGQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHL-m8A-yvONV6%2B3cRi-6gvdhb01RvxPU%2BHGejkS5XAGQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAFUsEtC7gt%3DK72C%2BjTcZJqbCEzao2CbkC8z%2BtX%2Bd_rxz-Fv9MQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAFUsEtC7gt%3DK72C%2BjTcZJqbCEzao2CbkC8z%2BtX%2Bd_rxz-Fv9MQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoF5Pcd_XBioi0_GH2%3Ddbjk7UkGXEA9e3Z31Zi1%3D1cPZag%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(oscarfh2) #5

I didn't know about this specific page, seems interesting, thanks!
:slight_smile:

2014-07-22 15:10 GMT-03:00 joergprante@gmail.com joergprante@gmail.com:

Not related to ES, but maybe you know about this help page?

https://wiki.apache.org/httpd/ReInflating

Jörg

On Tue, Jul 22, 2014 at 6:25 PM, Oscar oscarfh@gmail.com wrote:

I really can't make it work :frowning:
My elasticsearch is fronted by an Apache server, in which I am also
trying to compress the data, but for some reason I can't reduce the size of
the output.

2014-07-22 12:21 GMT-03:00 joergprante@gmail.com joergprante@gmail.com:

It works here

Setting:

http:
host: 127.0.0.1
compression: true

Response headers:

Content-Encoding: gzip
Content-Length: 225
Content-Type: application/json; charset=UTF-8

200 OK

Jörg

On Tue, Jul 22, 2014 at 3:09 PM, oscarfh2 oscarfh@gmail.com wrote:

Hi,
Elasticsearch si being used in my project and I am learning it now.
Currently we have a query that generates a large response and we would
like to compress the http response. To do so I added a key:
http.compression: true
in my elasticsearch.yml

If I make the query on Firefox (be acessing
localhost:9200/test/_search) I do not get the Content-Encoding:gzip as I do
on other websites.
The size (8kb) also doesn't change.

Is there anything else I have to do to compress the response?

Thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/21fbf526-599a-4bbb-8b0f-7a4fb583ec94%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/21fbf526-599a-4bbb-8b0f-7a4fb583ec94%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/KtwnOX1rDeM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHL-m8A-yvONV6%2B3cRi-6gvdhb01RvxPU%2BHGejkS5XAGQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHL-m8A-yvONV6%2B3cRi-6gvdhb01RvxPU%2BHGejkS5XAGQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAFUsEtC7gt%3DK72C%2BjTcZJqbCEzao2CbkC8z%2BtX%2Bd_rxz-Fv9MQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAFUsEtC7gt%3DK72C%2BjTcZJqbCEzao2CbkC8z%2BtX%2Bd_rxz-Fv9MQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/KtwnOX1rDeM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoF5Pcd_XBioi0_GH2%3Ddbjk7UkGXEA9e3Z31Zi1%3D1cPZag%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoF5Pcd_XBioi0_GH2%3Ddbjk7UkGXEA9e3Z31Zi1%3D1cPZag%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAFUsEtAsNWrQB1DAJMi68y7uq6c3LzzWeFLo03Wa7ifbdfkKAA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6