Compressing is not working perfectly


(jihyun suh) #1

I want to test the compression of elastic search. But I think it is not
working perfectly.
Someone knows about the compression?

  • tokenizer : standard

  • index compression : not use

  • size of index : 2.78G

  • tokenizer : standard

  • index compression : use

  • size of index : 3.00G

  • tokenizer : standard

  • source compression : use

  • size of index : 3.01G

  • tokenizer : n-gram(2-5level)

  • index compression : not use

  • size of index : 7.89G

  • tokenizer : n-gram(2-5level)

  • index compression : use

  • size of index : 8.01G

please help me...

--
View this message in context: http://elasticsearch-users.115913.n3.nabble.com/compressing-is-not-working-perfectly-tp4056057.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1400472570386-4056057.post%40n3.nabble.com.
For more options, visit https://groups.google.com/d/optout.


(Adrien Grand) #2

Hi,

What version of Elasticsearch are you using and how do you enable/disable
compression?

On Mon, May 19, 2014 at 6:09 AM, jihyun suh jhsuh.ourlight@gmail.comwrote:

I want to test the compression of elastic search. But I think it is not
working perfectly.
Someone knows about the compression?

  • tokenizer : standard

  • index compression : not use

  • size of index : 2.78G

  • tokenizer : standard

  • index compression : use

  • size of index : 3.00G

  • tokenizer : standard

  • source compression : use

  • size of index : 3.01G

  • tokenizer : n-gram(2-5level)

  • index compression : not use

  • size of index : 7.89G

  • tokenizer : n-gram(2-5level)

  • index compression : use

  • size of index : 8.01G

please help me...

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/compressing-is-not-working-perfectly-tp4056057.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1400472570386-4056057.post%40n3.nabble.com
.
For more options, visit https://groups.google.com/d/optout.

--
Adrien Grand

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAL6Z4j6pWMxDq-Qw1oc1DEiP0Gud1eENssv3_fVC_uyrOZbcAw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(jihyun suh) #3

= version of Elasticsearch
1.1.1

= how do you enable/disable compression?

  • index compression enable => index.store.compress.stored : true

  • index compression disable => default or index.store.compress.stored : false

  • _source compression enable => default or "_source" : { "compress" : true }

  • _source compression disable => "_source" : { "compress" : false }

= about _source compression :
I got some answer about _source compression from expert of elastic search.
He said that "source compression works, but it only make sense for really large docs, since there is already block compression on Lucene level. You should not turn it on 99% of the time".


(system) #4