Whenever I index the data, index size is different even though I set the same config and mapping


(Telax) #1

I would expect that it is because data is being distributed among shards and nodes differently automatically as you're using randomly generated ID's for your documents. Compression levels will always vary depending upon the data - you could have 100 consecutive rows with almost identical data giving good compression on one run but the next run they could be highly fragmented.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f5afa243-fce5-4a27-9d5c-625e5fd5b9fe%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

Have you set up shards = 1 / replica = 0 for your index to disable random
shard distribution by doc ID, and did you execute curl
'0:9200/yourindexname/_optimize?max_num_segments=1' after indexing to pack
all segments?

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/indices-optimize.html

Then you should see comparable results.

Jörg

On Tue, May 20, 2014 at 3:23 AM, ellie.suh@nexr.com wrote:

whenever I index the data, index size is different even though I set the
same config and mapping.
What happen to Elastic Search? Anybody knows about it? Please give me
hint...

  • tokenizer : standard
  • index compression : true
  • size of index : 2.78G
  • tokenizer : standard
  • index compression : true
  • size of index : 3.00G

3

  • tokenizer : standard
  • index compression : true
  • size of index : 2.89G

==============================
1.

  • tokenizer : standard
  • source compression : true
  • size of index : 3.12G
  • tokenizer : standard
  • source compression : true
  • size of index : 2.76G
  • tokenizer : standard
    -source compression : true
  • size of index : 2.91G

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/e7c2c32f-5521-4b32-8dfb-96de0dc225eb%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/e7c2c32f-5521-4b32-8dfb-96de0dc225eb%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFPqu3MrMi6Og1BYr99WuX%2B26J5d2T5fni-g%2BnNXnHTgg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(jihyun suh) #3

thanks~


(system) #4