Configuration Logstash 8.6.1 for monitoring VMWare server

I'm trying to send VMWare server parameters to Elastic Search node 8.6.1 passing by Logstash 8.6.1.
I obtained string in get option using Paessler MIB Importer.
I downloaded MIB file in official site of VMWare.

This is my logstash configuration file.

input {
  snmp {
    get => [ "" ]
    hosts => [{host => "udp:" version => "3"}]
	mib_paths => ["C:\Monitoring\logging\logstash-8.6.1-server\mibs"]
	security_name => "root"
	auth_protocol => "sha"
        auth_pass => "test2"
	priv_protocol => "aes128"
	priv_pass => "test2"
	interval => 30
	security_level => "authPriv"
output {
  elasticsearch {
		    hosts => ["https://XX.X.X.XXX:9200"]
			index => "server-%{+YYYY.MM.dd}"
			user => "elastic"
			password => "test"
			ssl => true
			ssl_certificate_verification => false

When I start logstash.bat I obtain this error:

You are getting a timeout while talking to on port 162.

Are you sure that the Logstash machine can talk with this address? Also, why port 162 instead of 161?

You want Logstash to poll your snmp data, so you should use port 161 which is used for pulling the data.

It looks like a network issue, please try to run a snmpwalk on the logstash server to see if it is working.

1 Like

Thanks. Changing the port I solved the problem.
For monitoring ram, cpu and storage informations that are present in the homepage of VMWare, what MIB file should I use?
I tried with VMWARE-RESOURCES-MIB AND VMWARE-OBSOLETE-MIB but I don't receive those specific informations.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.