Configure Kibana to use proxy

Hello

I have fresh cluster installation from docker images.
Docker images version's - 7.9.3

Server work in isolated network.
When i try look available plugins from kibana, application try connect directly to https://epr-7-9.elastic.co

I try set env in docker-compose but that dosn't help:

     environment:
         - "ES_JAVA_OPTS=-Xms5120m -Xmx5120m"
         - "ES_JAVA_OPTS=-Dhttp.proxyHost=https://proxy.local -Dhttp.proxyPort=8080 -Dhttps.proxyHost=https://proxy.local -Dhttps.proxyPort=8080"

But kibana try connect directly

Any idea how set proxy settings to kibana docker container?

What do the ES and Kibana logs suggest? Can you paste some information on that ?Do you see any errors in the browser console?

Can you share a HAR capture of all the network requests when you try to login? (Beware that the password will be visible in the capture so be sure to rotate it).

thanks
Rashmi

No any information about using proxy.

On tcpdump i see only attempt to directly connect.

May be mistake in evn configuration. Need another quotes or escaped quotes?

Did you has any work example for docker?

This hasn't been documented yet (see https://github.com/elastic/kibana/issues/78961), but you can use xpack.fleet.registryProxyUrl

Hello rudolf.

In Kibana 7.10 was added settings:

xpack.fleet.registryProxyUrl = "https://proxy.local"

That helped me to get packages behind proxy

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.