Configuring Filebeat to use proxy for any input request that goes out

I am running Elasticsearch, Kibana and Filebeats on my office windows laptop. I am trying to use filebeat -microsoft module. All outgoing http/s requests go via a proxy. How do I Configure Filebeat to use proxy for any input request that goes out (not just microsoft module). Setting HTTP_PROXY HTTPS_PROXY as environment variable does not seem to do the trick.

I see proxy setting for output to Elasticsearch & Kibana. But Is there configuration setting for proxy url for input requests ?

Yes, any module that uses the httpjson input has the var.proxy_url setting that u can set.

1 Like

I had the following entry in the microsoft module. It is not being used.

enabled: true
# How often the API should be polled
var.interval: 1m

var.proxy_url: proxy_domain_name:8080

If I set the proxy_domain_name the to HTTPS_PROXY then the curl command is working properly. Even after setting up filebeat module again, the proxy url is not recognised.

What version of filebeat?


What do the logs show? Any errors? Us the connection being attempted without the proxy even when it's set or just not working?

Thank you very much. var.proxy_url resolved the issue. I did not have the protocol (http://) as part of it earlier. Once I added it resolved the issue.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.