Configuring Input file on Windows


(DDA) #1

Hello,

I am trying to use an input file to feed a log file into Logstash on a Windows 2008 machine. However, it doesn't seem to be working properly.

My configuration file looks like this:

input {
file {
path => ["C:/Users/Admin/Desktop/Logs_elasticsearch/test_10292015.txt"]
start_position => "beginning"
}
}

And I run logstash using: logstash.bat -f test.conf

I tried using different combinations of basckslashes as well.

Thanks for your assistance.


(Magnus Bäck) #2

Logstash is probably tailing the file and waiting for more input. If you want to make sure it's processed from the beginning, shut down Logstash, delete the sincedb files, then start again.


(vani) #3

could you please tell me how to delete the sincedb files In logstash?


(Magnus Bäck) #4

The file input documentation will tell you the rules for where the sincedb files are created (unless you specify a path yourself). You can side-step that problem by picking a path yourself and setting it with sincedb_path.


(DDA) #5

Hi Magnus,

Would you have another solution? I shut down Logstash and restarted the application after deleting the files sincedb*.

Howver, I experiend the same situattion,

Thanks for your collaboration


(Magnus Bäck) #6

You can increase the level of logging by passing --verbose or even --debug. What output(s) do you have?


(system) #7