"Connection refused" when running curl -XGET 'localhost:9200'


#1

Hi All,

I recently installed and configured elasticsearch-readonly-rest-plugin- which BTW works really well, however I'm unable to connect into the elasticsearch now- am I missing on something?

When trying to import dashboards I'm receiving the same error as well. What will be the best way to connect into the elasticsearch via curl and using authentication.

Do i need to temporarily disable plugin and restart elasticsearch?

Thanks a million,

Tomek


(Isabel Drost-Fromm) #2

I'm not familiar with this plugin. Did you try and get in touch with it's original authors?

As an aside, may I ask what your use case for this plugin looks like? Sounds like something for which you might want to take a closer look at Shield

Sorry to have no more detailed answer,
Isabel


#3

Hi Isabel, thats perfectly fine I will reach out to the plugin developer.

As for the Shield- we are looking into that as well. I'm just "exploring" options at the moment...

Cheers, Tomek


(Isabel Drost-Fromm) #4

Sure - makes total sense. Would love to hear how your journey goes and what you end up using for your purpose. Would be great if you could keep this thread updated so others can benefit as well.

Isabel


#5

Thank you Isabel, will do.


(Mark O Stewart) #6

try to remove the plugin and see if your results change. You can always reinstall it after testing


#7

Thank you Mark, for the duration of my maintenance on elasticsearch i disabled plugin and than enabled it. It worked like a charm,

Cheers, Tomek


(system) #8