ElasticSearch: can't connect via curl


(Nilesh Date) #1

I am not able to connect via curl in elasticsearch.
Currently I am using single node which has everything(graylog apps, MongoDB, Elasticsearch).

Please assist.

root@node1:~# curl -XGET 'http://127.0.0.1:9200/_cluster/state'
curl: (7) Failed to connect to 127.0.0.1 port 9200: Connection refused
root@node1:~# curl -XGET 'http://localhost:9200/_cluster/state'
curl: (7) Failed to connect to localhost port 9200: Connection refused


(Magnus Bäck) #2

Is ES even? Is it bound to the loopback interface? Is there a firewall that might be blocking access?


(Nilesh Date) #3

Its working now.
I am using primary IP address instead of loopback.

Thanks,
Nilesh Date


(João Miguel) #4

Hello

I am implementing ElasticSearch , Logstash , and Kibana ( ELK Stack) on Ubuntu 15.10 but got to a step that is :

Load Kibana Dashboards :
beats - dashboards- cd *
./load.sh

after entering the command gives me this error :
curl : ( 7) Failed to connect to localhost port 9200 : Conection refused

Can help please

Thank you


(David Pilato) #5

Start your own thread instead of answering a very old one.


(João Miguel) #6

Thank You David.

Done.

Best Regards


(MT) #7

Had the same problem. What fixed it for me was commenting out the proxy settings i had in my .bash_profile. But i am afraid thats if you have a proxy on.


(João Miguel) #8

no proxy configured.


(system) #9