Corrupt index removal

I've a small index that contains only a time stamp on a three node ES deployment.
However its stuck initializing and there are no allocated secondary's.
As the data in this index is unimportant I planed to just remove it and recreate the index.
However I was unable to delete this index

[2023-11-15T13:37:04,385][DEBUG][o.e.a.a.i.d.TransportDeleteIndexAction] [masterserver1] failed to delete indices [[[mysmallindex/2GqYWer0T4igq8FNVKSnkA]]]
org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException: failed to process cluster event (delete-index [[mysmallindex/2GqYWer0T4igq8FNVKSnkA]]) within 30s

I tried the delete command with a time out of 120 with the same result.

Any advice on how to remove a index/shard which is initializing welcomed. I am not concerned about data loss in this situation.


What is the full output of the cluster stats API? What is the size and specification of the cluster?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.