Could not get resource 'https://plugins.gradle.org/m2/com/gradle/build-scan/com.gradle.build-scan.gradle.plugin/1.13.2/com.gradle.build-scan.gradle.plugin-1.13.2.jar'


(Wonho Choi) #1

I've run ES master branch (7.0.0-Alpha) with gradle run

But It showed
Error resolving plugin [id: 'com.gradle.build-scan', version: '1.13.2']

Could not resolve all dependencies for configuration 'detachedConfiguration1'.
Could not determine artifacts for com.gradle.build-scan:com.gradle.build-scan.gradle.plugin:1.13.2
Could not get resource 'https://plugins.gradle.org/m2/com/gradle/build-scan/com.gradle.build-scan.gradle.plugin/1.13.2/com.gradle.build-scan.gradle.plugin-1.13.2.jar'.
Could not HEAD 'https://plugins.gradle.org/m2/com/gradle/build-scan/com.gradle.build-scan.gradle.plugin/1.13.2/com.gradle.build-scan.gradle.plugin-1.13.2.jar'.
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

I wonder that Is there the resource? or my network firewall problem?

ps : https://repo.jfrog.org/artifactory/libs-release-bintray/com/gradle/build-scan/com.gradle.build-scan.gradle.plugin/1.13.2/com.gradle.build-scan.gradle.plugin-1.13.2.jar?referrer is 404 error


(Tim Vernum) #2

This is a TLS error. Your JVM doesn't trust the cert for plugins.gradle.org.
My guess is that you're running OpenJDK 10, which ships with an incomplete list of CA certs.

You'll either need to run Oracle JDK 10, or update your JRE's cacerts with a more comprehensive list.

This issue & associated commits shows how we did that for the Elasticsearch docker images.


(Wonho Choi) #3

Thanks for the reply
According to your reply I've found some article like - https://github.com/gradle/gradle/issues/5051
But Sadly I'm using oracle jdk 10 and couldn't fix it.
I'm trying to find com.gradle.build-scan cacerts
If I fix it, I'll touch this article


(Tim Vernum) #4

Are you behind a corporate proxy?

Some proxies intercept TLS traffic by replacing the certificates for all sites with their own, signed by their own CA. If you have such a proxy then you will either need to by-pass it (which is not likely to be easy) or install the proxy's CA into your JVM's cacert file (which is not good for your security, but you don't have much choice here).


(Wonho Choi) #5

Now, I'm behind my company net, But I've tried at my home and got same result.
Also tried using external network like phone lTE net. Anyway I'll try at home again when I After work(Here is Korea, and now is AM). So In the meantime, I'm trying to find install ca into my cacert file.
If I got a way, I'll wrote that~


(Wonho Choi) #6

Problem is a corporate proxy.
I can run at my home.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.