Elasticsearch Gradle build failed: PKIX path building failed

P1: git clone https://github.com/elastic/elasticsearch.git elasticsearch

P2: import https://jcenter.bintray.com certification to JAVA_HOME/lib/security/cacerts
I'm sure the certification added success

P3: ./gradlew assemble
aslo tried add config -Djavax.net.ssl.trustStore="JAVA_HOME/lib/security/cacerts"

But Run Error:

Execution failed for task ':buildSrc:compileJava'.
> Could not resolve all files for configuration ':buildSrc:compileClasspath'.
   > Could not resolve commons-codec:commons-codec:1.12.
     Required by:
         project :buildSrc
      > Could not resolve commons-codec:commons-codec:1.12.
         > Could not get resource 'https://jcenter.bintray.com/commons-codec/commons-codec/1.12/commons-codec-1.12.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/commons-codec/commons-codec/1.12/commons-codec-1.12.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve org.apache.commons:commons-compress:1.19.
     Required by:
         project :buildSrc
      > Could not resolve org.apache.commons:commons-compress:1.19.
         > Could not get resource 'https://jcenter.bintray.com/org/apache/commons/commons-compress/1.19/commons-compress-1.19.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/org/apache/commons/commons-compress/1.19/commons-compress-1.19.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve com.netflix.nebula:gradle-extra-configurations-plugin:3.0.3.
     Required by:
         project :buildSrc
      > Could not resolve com.netflix.nebula:gradle-extra-configurations-plugin:3.0.3.
         > Could not get resource 'https://jcenter.bintray.com/com/netflix/nebula/gradle-extra-configurations-plugin/3.0.3/gradle-extra-configurations-plugin-3.0.3.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/com/netflix/nebula/gradle-extra-configurations-plugin/3.0.3/gradle-extra-configurations-plugin-3.0.3.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve com.netflix.nebula:nebula-publishing-plugin:4.4.4.
     Required by:
         project :buildSrc
      > Could not resolve com.netflix.nebula:nebula-publishing-plugin:4.4.4.
         > Could not get resource 'https://jcenter.bintray.com/com/netflix/nebula/nebula-publishing-plugin/4.4.4/nebula-publishing-plugin-4.4.4.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/com/netflix/nebula/nebula-publishing-plugin/4.4.4/nebula-publishing-plugin-4.4.4.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve com.netflix.nebula:gradle-info-plugin:7.1.3.
     Required by:
         project :buildSrc
      > Could not resolve com.netflix.nebula:gradle-info-plugin:7.1.3.
         > Could not get resource 'https://jcenter.bintray.com/com/netflix/nebula/gradle-info-plugin/7.1.3/gradle-info-plugin-7.1.3.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/com/netflix/nebula/gradle-info-plugin/7.1.3/gradle-info-plugin-7.1.3.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve org.apache.rat:apache-rat:0.11.
     Required by:
         project :buildSrc
      > Could not resolve org.apache.rat:apache-rat:0.11.
         > Could not get resource 'https://jcenter.bintray.com/org/apache/rat/apache-rat/0.11/apache-rat-0.11.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/org/apache/rat/apache-rat/0.11/apache-rat-0.11.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve org.elasticsearch:jna:5.5.0.
     Required by:
         project :buildSrc
      > Could not resolve org.elasticsearch:jna:5.5.0.
         > Could not get resource 'https://jcenter.bintray.com/org/elasticsearch/jna/5.5.0/jna-5.5.0.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/org/elasticsearch/jna/5.5.0/jna-5.5.0.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve com.github.jengelman.gradle.plugins:shadow:5.1.0.
     Required by:
         project :buildSrc
      > Could not resolve com.github.jengelman.gradle.plugins:shadow:5.1.0.
         > Could not get resource 'https://jcenter.bintray.com/com/github/jengelman/gradle/plugins/shadow/5.1.0/shadow-5.1.0.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/com/github/jengelman/gradle/plugins/shadow/5.1.0/shadow-5.1.0.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve de.thetaphi:forbiddenapis:3.0.
     Required by:
         project :buildSrc
      > Could not resolve de.thetaphi:forbiddenapis:3.0.
         > Could not get resource 'https://jcenter.bintray.com/de/thetaphi/forbiddenapis/3.0/forbiddenapis-3.0.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/de/thetaphi/forbiddenapis/3.0/forbiddenapis-3.0.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve com.avast.gradle:gradle-docker-compose-plugin:0.12.1.
     Required by:
         project :buildSrc
      > Could not resolve com.avast.gradle:gradle-docker-compose-plugin:0.12.1.
         > Could not get resource 'https://jcenter.bintray.com/com/avast/gradle/gradle-docker-compose-plugin/0.12.1/gradle-docker-compose-plugin-0.12.1.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/com/avast/gradle/gradle-docker-compose-plugin/0.12.1/gradle-docker-compose-plugin-0.12.1.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve org.apache.maven:maven-model:3.6.2.
     Required by:
         project :buildSrc
      > Could not resolve org.apache.maven:maven-model:3.6.2.
         > Could not get resource 'https://jcenter.bintray.com/org/apache/maven/maven-model/3.6.2/maven-model-3.6.2.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/org/apache/maven/maven-model/3.6.2/maven-model-3.6.2.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve com.networknt:json-schema-validator:1.0.36.
     Required by:
         project :buildSrc
      > Could not resolve com.networknt:json-schema-validator:1.0.36.
         > Could not get resource 'https://jcenter.bintray.com/com/networknt/json-schema-validator/1.0.36/json-schema-validator-1.0.36.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/com/networknt/json-schema-validator/1.0.36/json-schema-validator-1.0.36.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
   > Could not resolve com.puppycrawl.tools:checkstyle:8.20.
     Required by:
         project :buildSrc
      > Could not resolve com.puppycrawl.tools:checkstyle:8.20.
         > Could not get resource 'https://jcenter.bintray.com/com/puppycrawl/tools/checkstyle/8.20/checkstyle-8.20.pom'.
            > Could not HEAD 'https://jcenter.bintray.com/com/puppycrawl/tools/checkstyle/8.20/checkstyle-8.20.pom'.
               > PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.