Creating node in elasticsearch


(Aniket) #1

I have just install elasticsearch 5.0.0. When I run 'localhost:9200/_cat/nodes?v' it gives me ip as 10.57.203.16. But I want local host as a server. Where should I configure it ?


#2

Did you make any changes in elasticsearch.yml regarding options mentioned in https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-network.html ?


(Aniket) #3

Yes I have made two changes.

cluster.name: elastic_test
network.host: localhost

Should I make any other change ?


#4

Try to leave out the network.host option. As is stated in the docs:

Elasticsearch binds to localhost only by default

So if you do not fiddle with these settings, it should listen only on loopback interfaces.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.