CSV Export Kibana 6.0 missing new line

I've started to use Kibana 6.0 and tried the new CSV Export functionality. However the export is missing new line, so everything is on the same row. Exported rows should have new line in between. So it's not yet useful for us. Anyone else experiencing this issue?

Hey @undelete which application are you using to view the exported CSV? Kibana is currently exporting all CSVs using Unix line endings (just a line feed "\n"), so if you're opening the CSV in something like Notepad on Windows you likely won't see multiple lines.

I use IE 11. When I go in to Management / Reporting and press download on the report a new browserwindow is opened and the export is there in csv-format, but there is never a csv-file that is actually downloaded. So I just copy all the content in this webpage and pasting in Microsoft Excel / Notepad++. But none of them see the \n (new line).

Edit: I tried another approach, I saved the webpage (Save as) as a .csv-file. Then it worked better, but it feels like a workaround. I would prefer to just get a csv-file to download when I press the download button and not open a huge text-blob in a new browser window.

@undelete I agree, I'll see what I can do to improve that behavior.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.