CSV Export wrong @timestamp

Hi all,

I have a date filter in logstash as below :

date {
   match => ["[@metadata][timestamp]", "ISO8601"]
   timezone => "Asia/Kuala_Lumpur"
}

However, when I try to export into CSV, the @timestamp field is always in UTC time.
Is there any way I can show it in Asia/Kuala_Lumpur time?

Thanks

Hello

There is a bug like this: https://github.com/elastic/kibana/issues/56497
So you will have to change the dateFormat:tz setting in Advanced Settings in your Kibana instance, then the CSV export will take that timezone in consideration when exporting the data.

Hi Marius_Dragomir,

Thanks for the input! It works when I change the dateFormat:tz setting!

1 Like