CSV exported losing timezone setting

Hi all,

Our kibana 7.12 started to show this behaviour (we are using Elastic Cloud).
The dashboards show the timestamp formatted correctly as the Advanced Settings were chosen to be America/Sao_Paulo.
So the dashboard usually had a row with timestamp 15h00, and the JSON was in UTC (18h00). When we exported the CSV it came correctly as 15h00.

Now when we export the CSV it keeps with the UTC date.
We already rebooted Kibana, and tried to change the timezone in the Advanced Settings to "Browser" and to "America/East" to see if there is any change, but the timestamp keeps showing in UTC when we export the CSV.

Hi @marcosvrrs, could you post the exact steps to reproduce here? I tried to export a datatable from Dashboard to CSV, but it works correctly for me.

Hi @Marta_Bondyra , thanks for the reply!

So, first we have a dashboard like this:

Then I go over the 3 dots, select more, and select "Download CSV" :


And the exported CSV with the 3 hours difference:

Sorry for the blurred images. Hope you can understand.

@Marta_Bondyra I tried with a saved search through discover, and the exact same thing happens. So, both ways the same issue shows.

Thanks, finally I was able to reproduce it in 7.12. Looks like it is fixed for the upcoming version 7.13, but I'll go through the list of our issues and see if we plan to merge a fix for 7.12.2.

@Marta_Bondyra thanks for the reply. When is this fix coming? Do you have an expected day of the release? It has broken a few scripts that are critical for our daily routines.

(this 7.12 version is so painful. We caught a MAJOR bug in the 7.12 few weeks ago and had our cluster offline until the elastic dev team fixed in 3 patches)

I'm really sorry to hear it!

Unfortunately, I cannot give you exact date of the release, but it will be released in about a month. Seeing how critical it is for you, I will try to advocate also for releasing this fix for 7.12.2 (which will happen much sooner).
Sorry one more time and thank you for your patience.

1 Like

Hi @marcosvrrs,

I found out about workaround: in the index pattern, the date field needs explicit formatting as date .

  1. Open the index pattern, find the date field
  2. Click the pencil on the field row
    date formatting
  3. Set format to Date
    date format 2
    After setting the date format, the index pattern field list will show Date under the Format header, as shown in the first screenshot.
  4. In the CSV export, this field will be formatted correctly and use the correct time zone:

This is happening because the "default" field formats are not being applied due to a bug. Just like I mentioned, this will be fixed in 7.13 with elastic/kibana#88303

1 Like

Hi @Marta_Bondyra, thanks for the workaround, it worked.
Have a nice day! :smiley:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.