CSV River showing unexpected results in a 3 node cluster


(Sree) #1

Hi all,

I have a 3 node cluster . One is Master and others are eligible for master
when the master node failed. I installed CSV River plugin in master node.
The csv files which need to process is also in master node. When i am
running the CSV river plugin from master , then it trying to execute the
indexing in other nodes and it fails in finding the csv files. Because csv
files are in master.

Any pointers on this. Is this an expected behaviour ?

Thank you,

Srijith

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c64b88ce-1f3c-4966-bd42-d9845e91ef36%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

I think you could set in elasticsearch.yml:

node.river: none

On nodes you don't want to allocate any river.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 12 août 2014 à 15:01:27, Sree (srssreejith@gmail.com) a écrit:

Hi all,

I have a 3 node cluster . One is Master and others are eligible for master when the master node failed. I installed CSV River plugin in master node. The csv files which need to process is also in master node. When i am running the CSV river plugin from master , then it trying to execute the indexing in other nodes and it fails in finding the csv files. Because csv files are in master.

Any pointers on this. Is this an expected behaviour ?

Thank you,

Srijith

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c64b88ce-1f3c-4966-bd42-d9845e91ef36%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53ea11f8.2ca88611.18f0%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Sree) #3

Hi David,

Thank you very much. It worked.

On Tuesday, 12 August 2014 18:39:28 UTC+5:30, David Pilato wrote:

I think you could set in elasticsearch.yml:

node.river: none

On nodes you don't want to allocate any river.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 12 août 2014 à 15:01:27, Sree (srssr...@gmail.com <javascript:>) a
écrit:

Hi all,

I have a 3 node cluster . One is Master and others are eligible for master
when the master node failed. I installed CSV River plugin in master node.
The csv files which need to process is also in master node. When i am
running the CSV river plugin from master , then it trying to execute the
indexing in other nodes and it fails in finding the csv files. Because csv
files are in master.

Any pointers on this. Is this an expected behaviour ?

Thank you,

Srijith

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c64b88ce-1f3c-4966-bd42-d9845e91ef36%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c64b88ce-1f3c-4966-bd42-d9845e91ef36%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0986eb43-8834-44dc-8772-f07258825b59%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4