Curator 3


(Wendel Ferreira) #1

Pessoal, boa tarde.

 Depois que atualizei o elasticsearch para a 1.5 vi que a rotinha no 

crontab do curator parou de funcionar.
Eu estava lendo a documentação em
https://www.elastic.co/blog/curator-3-0-released e vi que mudou algumas
coisas.

A linha do contrab do curator 2 que eu tinha era esta (excluir logs com
mais de 90 dias):
curator delete --older-than 90

Versão do Elasticsearch

rpm -qa | grep elas

elasticsearch-1.5.1-1.noarch

Temo como fazer de uma forma mais simples do que na documentação?
Exemplo:
curator delete indices --older-than 30 --newer-than 60 --time-unit days

--timestring '%Y.%m.%d' --prefix logs --suffix prod
--exclude logs-2015.02.01-prod --exclude 2015.01.31
--index logs-2015.02.01-dev

Qual seria o comando equivalente na versão 3 para excluir logs/indices com
mais de 90 dias?

Desde já obrigado.

Att.
Wendel Ferreira

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5ca88993-869b-4b54-85c3-c8324afea27a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Magnus Bäck) #2

On Tuesday, May 12, 2015 at 21:06 CEST,
Wendel Ferreira wendelmineiro89@gmail.com wrote:

Pessoal, boa tarde.
Depois que atualizei o elasticsearch para a 1.5 vi que a rotinha
no crontab do curator parou de funcionar.

This mailing list is in English. The new discussion forum that's
replacing this list has a couple of non-English categories but
currently none for Portuguese (if that indeed is your preferred
language).

[...]

--
Magnus Bäck | Software Engineer, Development Tools
magnus.back@sonymobile.com | Sony Mobile Communications

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/20150512201102.GA2679%40seldlx20533.corpusers.net.
For more options, visit https://groups.google.com/d/optout.


(system) #3