Curator 5.7.6 unable to restore deleted index from snap

Hi there,

When executing a restore yml action file to restore a deleted index from a snapshot located on a repository it fails with the following.

Failed to complete action: restore. <class 'curator.exceptions.FailedExecution'>: Exception encountered. Rerun with loglevel DEBUG and/or check Elasticsearch logs for more information. Exception: Unable to obtain recovery information for specified indices. Error: NotFoundError(404, 'index_not_found_exception', 'no such index', graylog_xxx, index_or_alias)

We use graylog2 3.0, elasticsearch 6.8.2 and curator 5.7.6 in a three node cluster.
Recently we did update elasticsearch from 5.6 although i am unsure if it did indeed work prior to this update.

Restore action file

actions:
  1:
    action: restore
    description: >-
      Restore all indices in the most recent snapshot with state SUCCESS.  Wait
      for the restore to complete before continuing.  Do not skip the repository
      filesystem access check.  Use the other options to define the index/shard
      settings for the restore.
    options:
      repository: "my_backup"
      # If name is blank, the most recent snapshot by age will be selected
      name: curator-xxxxxx
      # If indices is blank, all indices in the snapshot will be restored
      indices:
      - graylog_xxxx
      wait_for_completion: True
      max_wait: 3600
      wait_interval: 10
    filters:
    - filtertype: state
      state: SUCCESS
      exclude:

I can verify the repo successfully and i have determined that the index being restored is located in the snapshot.

curl -XGET "localhost:9200/_snapshot/my_backup/curator-xxxxxxxxx?format=json&pretty"

I get the same response if i choose another index with the same or different snapshot.

snapshot action file

actions:
  1:
    action: snapshot
    description: >-
      Snapshot indices older than 1 hours (based on index
      creation_date) with the default snapshot name pattern of
      'curator-%Y%m%d%H%M%S'.  Wait for the snapshot to complete.  Do not skip
      the repository filesystem access check.
    options:
      repository: "my_backup"
      # Leaving name blank will result in the default 'curator-%Y%m%d%H%M%S'
      name:
      ignore_unavailable: False
      include_global_state: True
      partial: False
      wait_for_completion: True
      skip_repo_fs_check: False
      disable_action: False
    filters:
    - filtertype: age
      source: creation_date
      direction: older
      unit: day
      unit_count: 1

Any help would be appreciated.

Thanks