Curl commands to set Marvel settings


(Ramdev Wudali) #1

Hi All:
I am trying to prevent Marvel from creating the indices for each day
automatically. I know there is a curl command to do that. I am not able to
find it in any of the documentation that is available. Other than setting
it in the config file and have to restart my instance is there a way to do
it ?

(and can various ES settings be changed the same way ?)

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6383efbe-cafe-48cb-8ee9-03b8f1dd1b0b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #2

Hi Ramdev,

Do you want marvel to stop sending data? The best settings is
marvel.agent.enabled: false but that can only be set in the
elasticsearch.yml and requires a node restart. As an alternative you can
this (assuming you have a decently recent marvel version):

curl -XPUT "http://localhost:9200/_cluster/settings" -d'
{
"persistent": {
"marvel.agent.interval": "-1"
}
}'

This will not disable the agent but stop it from sampling and shipping data.

Cheers,
Boaz

On Tuesday, June 3, 2014 10:24:15 PM UTC+2, Ramdev Wudali wrote:

Hi All:
I am trying to prevent Marvel from creating the indices for each day
automatically. I know there is a curl command to do that. I am not able to
find it in any of the documentation that is available. Other than setting
it in the config file and have to restart my instance is there a way to do
it ?

(and can various ES settings be changed the same way ?)

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/857ee53a-7d03-4213-a1a2-364c6af78886%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Ramdev Wudali) #3

Hi Boaz:
Couldn't I do the same curl command to disable the agent ? or is that
setting something that inly recognized on a ES (re)start ?

Thanks

Ramdev

On Tue, Jun 3, 2014 at 3:55 PM, Boaz Leskes b.leskes@gmail.com wrote:

Hi Ramdev,

Do you want marvel to stop sending data? The best settings is
marvel.agent.enabled: false but that can only be set in the
elasticsearch.yml and requires a node restart. As an alternative you can
this (assuming you have a decently recent marvel version):

curl -XPUT "http://localhost:9200/_cluster/settings" -d'
{
"persistent": {
"marvel.agent.interval": "-1"
}
}'

This will not disable the agent but stop it from sampling and shipping
data.

Cheers,
Boaz

On Tuesday, June 3, 2014 10:24:15 PM UTC+2, Ramdev Wudali wrote:

Hi All:
I am trying to prevent Marvel from creating the indices for each day
automatically. I know there is a curl command to do that. I am not able to
find it in any of the documentation that is available. Other than setting
it in the config file and have to restart my instance is there a way to do
it ?

(and can various ES settings be changed the same way ?)

Thanks

Ramdev

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/Celm5RDoC-0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/857ee53a-7d03-4213-a1a2-364c6af78886%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/857ee53a-7d03-4213-a1a2-364c6af78886%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7goqRhjQvZ4giw9XF54%2B9tdh2cacFhy9vVkxG2Kk-j9iw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #4

At the moment the enabled option is only read on restart. What I suggest
you do is add that setting to all your elasticsearch.yml files and also run
the following command

curl -XPUT "http://localhost:9200/_cluster/settings" -d'
{
"transient": {
"marvel.agent.interval": "-1"
}
}'

This will make the agent not sample data (and thus effectively be disabled)
until you restart the node - at which point the enabled: false setting will
be picked up

On Tue, Jun 3, 2014 at 11:01 PM, Ramdev Wudali agastya71@gmail.com wrote:

Hi Boaz:
Couldn't I do the same curl command to disable the agent ? or is that
setting something that inly recognized on a ES (re)start ?

Thanks

Ramdev

On Tue, Jun 3, 2014 at 3:55 PM, Boaz Leskes b.leskes@gmail.com wrote:

Hi Ramdev,

Do you want marvel to stop sending data? The best settings is
marvel.agent.enabled: false but that can only be set in the
elasticsearch.yml and requires a node restart. As an alternative you can
this (assuming you have a decently recent marvel version):

curl -XPUT "http://localhost:9200/_cluster/settings" -d'
{
"persistent": {
"marvel.agent.interval": "-1"
}
}'

This will not disable the agent but stop it from sampling and shipping
data.

Cheers,
Boaz

On Tuesday, June 3, 2014 10:24:15 PM UTC+2, Ramdev Wudali wrote:

Hi All:
I am trying to prevent Marvel from creating the indices for each day
automatically. I know there is a curl command to do that. I am not able to
find it in any of the documentation that is available. Other than setting
it in the config file and have to restart my instance is there a way to do
it ?

(and can various ES settings be changed the same way ?)

Thanks

Ramdev

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/Celm5RDoC-0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/857ee53a-7d03-4213-a1a2-364c6af78886%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/857ee53a-7d03-4213-a1a2-364c6af78886%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/Celm5RDoC-0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7goqRhjQvZ4giw9XF54%2B9tdh2cacFhy9vVkxG2Kk-j9iw%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7goqRhjQvZ4giw9XF54%2B9tdh2cacFhy9vVkxG2Kk-j9iw%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKzwz0q9bMVQ-XKmER%3DKSTA4cRX9tT4KNOgvvDzDgAWR-uhJcA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5