Other elasticsearch settings required

monitoring

(Arpan Shah) #1

I installed marvel on all my elasticsearch nodes and then on kibana. I am not seeing any data currently. Upon investigation when I ran curl -XGET 'http://localhost:9200/_cat/indices?v' , I do not see any marvel related index.

I was wondering what other settings need to be in place for marvel to work: From my legacy settings of 1.7 I have these two lines:

marvel.agent.enabled: false
action.auto_create_index: false

The first one has changed so I wasn't sure if it is still impacting the creation. The second one is there for security purposes so that random indexes don't arbitrarily get created.

What are the settings that NEED to be there in the elasticsearch.yml for marvel to work?


(Chris Earle) #2

Which version of Elasticsearch are you running? Can you also run and show the results of:

$ curl -XGET localhost:9200/_cat/plugins?v

What are the settings that NEED to be there in the elasticsearch.yml for marvel to work?

By default, absolutely no settings are required to make Marvel work. If nothing is configured and it's not disabled, [which is explicit,] then it will report metrics to itself.

marvel.agent.enabled: false

As you alluded to, this has become marvel.enabled: false now, so the setting will be ignored. That said, it seems to be undesirable to keep useless settings around.

action.auto_create_index: false

This will actively prevent any index that "just" gets created by defining a template and then indexing documents, like Marvel. As a result, it should be:

action.auto_create_index: .marvel-*

Hope that helps,
Chris


(system) #3