Marvel no results

monitoring

(Eugene Prokopiev) #1

Hi,

I have installed marvel as plugin but I can't see any data. I see only error message "No results There were no results because no indices were found that match your selected time span". Other plugins like http://www.elastichq.org/support_plugin.html works fine.

My cluster name is differ from default, may be this is reason?


Error : New Elasticsearch Installation
(Mark Walkom) #2

Did you restart ES after installing it?
You should see something like loaded [marvel], sites [marvel] in your logs to show that it has been correctly loaded.


(Eugene Prokopiev) #3

Yes, ES was restarted and I see:

[2015-07-23 10:15:50,165][INFO ][plugins                  ] [data] loaded [marvel, index-termlist-1.5.2.0-39dcf68], sites [marvel, inquisitor, calaca, kopf, head, HQ]
[2015-07-23 10:15:54,597][INFO ][marvel.agent             ] [data] collecting disabled by settings

But I still see "No results" error


(Mark Walkom) #4

Can you post/link to your ES config?


(Eugene Prokopiev) #5
# grep -v '^$\|^\s*\#' /etc/elasticsearch/elasticsearch.yml
cluster.name: event
node.name: "data"
bootstrap.mlockall: true
http.cors.enabled: true
marvel.agent.enabled: false

(Mark Walkom) #6

That's why, why do you have that?


(Eugene Prokopiev) #7

due to https://www.elastic.co/guide/en/elasticsearch/guide/current/_installing_elasticsearch.html :smile:

Thanks, it helps


(Mark Walkom) #8

Oh ok, the docs are a little unclear as that refers to https://www.elastic.co/guide/en/marvel/current/_installation.html#_installing_a_secondary_monitoring_cluster

Will see what we can do to fix that :slight_smile:


(system) #9