Curl request problem


(Nivo33) #1

Hi,
I am trying to send a request through curl, for example:

curl -XGET 'localhost:9200/_search?pretty' -H 'Content-Type: application/json' -d'
{
    "query" : {
        "term" : { "user" : "kimchy" }
    }
}
'

The response I am getting is (no matter which request is sent):
Galera cluster node is synced.

Any idea why this is? When I send the request through Kibana in the Dev Tools section like this, it works fine:
GET /_search { "query" : { "term" : { "user" : "kimchy" } } }

Thanks


(David Pilato) #2

Where is this Galera cluster node is synced. is coming from?

I mean: do you see that in elasticsearch logs?

Can you share the full output and your logs?


(Nivo33) #3

It is coming from the CLI of the machine I am running it on and that is unfortunately the full output.
The elasticsearch logs don't show anything relevant, they do not update after i run the command.
I am using docker if it helps anything


(David Pilato) #4

Is that really elasticsearch answering behind the scene or this? http://galeracluster.com/products/


(Nivo33) #5

Thanks, you were right.
I was rerouting through docker. Problem solved


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.