Custom regionmap not working

I get error “Cannot download file. Please ensure the CORS configuration of the server permits requests from the Kibana application on this host.” although I don’t see any error in the console and there is a valid response (See the attached screenshot). Please advise.


In the blog post we give an example of using http-server --cors='*' -p 8000 . But I've found that http-server --cors="kbn-version" -p 8000 works better. You'll probably want to update server.cors.origin in your config/kibana.yml.

There were other discuss posts which had the same solution: CORS problem in Kibana Map

relevant ticket:

hopefully this works, good luck


1 Like

Hi Rashmi,

I read all the tickets that are related to my issue and none of them worked with me. Unfortunately, your reply is unhelpful as well. If you check my geojson link, you can notice that I already enabled CORS and added kbn-version.

Also, adding server.cors.origin in kibana.yml is not working too because it's not allowing to do that and gives me error "'server.cors.origin': is not allowed".

I hope that someone robust from Elastic team can investigate this issue and answer me. I noticed many people face the same problem without any solution.

Thank you,


Hello Zakwan,

If you check my geojson link, you can notice that I already enabled CORS and added kbn-version.

Doing a test GET against your server providing GeoJSON, I'm not seeing anything like the following in the response-headers:

Access-Control-Allow-Headers: origin,x-requested-with,content-type,accept,range,kbn-version

That second link that @rashmi provided, which you also commented on provides a link on how to configure this setting on one server, but the specifics of how to do it are likely different for your server. With regard to your comment there on reopening the issue, let's hold off that until we've firmly established there's a common issue that others are likely to experience.

For your response headers, if you believe differently, could you please provide a screenshot of what you're seeing?

Some of the other guidance in that issue is also still good. Is there any chance you can update to > 6.5? Even better, if you can use a version newer than 6.7, you'd get access to the new Maps App which will be replacing the map product you're using now in the long run and receives more frequent improvements and updates.


1 Like

I updated to 6.8.8 and it works well.

1 Like

Glad it worked for you on 6.8.8.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.