Custum beat exemple in documentation problem


(Boubker Elamri) #1

hi everyone,

I was learning how to create beats this days, and i found out an lsbeat exemple on the documentations, I followed the instruction one by one, and the lsbeat compiled with success. However, when I tried to execute the ./lsbeat it executes but i couldn't view the index on elasticsearch when I go to "localhost:9200/_cat/indices. can someone help me please .


(Steffen Siering) #2

Hi,

can you try console or file output first (disable elasticsearch output), to verify your beat correctly creates events.

You can enable debug output by starting your beat with -d '*'.

Also check the logs for ERR messages. Maybe the problem is the connection or template loading?


(Boubker Elamri) #3

hi,

Thanks for the response, I tried to do "./lsbeat -d "*" but the terminal
doesn't show the debugging.
thanks


(Steffen Siering) #4

Oh Sorry, you have to use -e to print to stderr.


(Boubker Elamri) #5

Also -e doesn't work.


(Boubker Elamri) #6

i found out the solution, i had a problem on the main.go code
thanks for the help
best regards


(system) #7

This topic was automatically closed after 21 days. New replies are no longer allowed.