Data Format Conversion From Kibana not working for Range buckets

I have an index pattern having a field that contains data in microseconds format. After ingesting the data , i am changing the format of the field from Kibana to show the data in seconds format . When I am seeing the data in discover , the data format of the field is coming as seconds but when I am trying to create a datatable visualisation with range buckets based on that field , the data is not going into proper buckets if i use seconds to define the range buckets . However when i use microseconds to define the range buckets , the data is going into proper buckets. Any idea why this is happening ?

As a workaround , I have used ruby filter in logstash itself to convert the data on that field from microsecond to second while ingesting into Elasticsearch. This approach works fine but i want to understand why the conversion from Kibana is not working .


I think this is a bug I recently fixed, released in 7.7.0:

The screenshot in that shows it on the bar chart visualization, but it works on tables as well.

Thanks for the update Wylie . Is there any plugin or patch available to fix the issue is lower versions like 7.5 or 7.4 ? Upgrading to 7.7 is an option but i want to understand if there is ant other solution apart from upgrading.

It sounds like you already have a workaround, and I don't have any additional workaround to offer. It's not part of our process to release minor patches to older versions, because it would require you to upgrade the entire stack.

Thanks Wylie . We will plan for the upgrade then and continue using the workaround with ruby in the interim.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.