] [data_node_1] not enough master nodes discovered during pinging (found [[]], but needed [1]), pinging again

Hi I have two two node cluster on red hat Enterprise Linux server . Both nodes are running on different different server. when i run elastic search for the server having data node ,getting such error

Hi Nidhi,

Could you please share the full logs and 'elasticsearch.yml' file for investigating the same.

Harsh Bajaj

Hi Harsh,

I have shared the logs and configurations.

Thanks & Regards,

Hi Nidhi,

Thank you !

Are you able to telnet on port :9300 on your both machines?

Maybe firewall rule is preventing these nodes from communicating. Please check following things to make sure that there is no problem related to network.

  1. Ping (On both nodes)
  2. curl http://:9300 (on both nodes)
  3. telnet (on both node)

Please share the o/p for more investigation.

Harsh Bajaj

This is the reason that both the nodes are not able to communicate.

You need to add/enable port in firewall or check IPtables.

Harsh Bajaj

Can u please tell me how to enable the ports

HI NIdhi,

Could you please let me know which OS/environment is using?

Harsh Bajaj

Harsh, I am using Red hat Enterprise Linux server.

Hi Nidhi,

Could you please share the o/p of below commands on both the machines.

netstat -nlp |grep 9200

netstat -nlp | grep 9300

Harsh Bajaj

Hi Harsh,

For both server it is not showing anything.
[root@blt07163059 ~]# netstat -nlp |grep 9200
[root@blt07163059 ~]# netstat -nlp |grep 9300
[root@blt07163059 ~]#


Please make sure your elasticsearch service is in running state.

Yes, It seems your ealsticsearch service is not running.

I'm not able to understand why you are getting this message if you have already installed elasticsearch on your machine.

can i know how you install elastocsearch ?

Harsh Bajaj

and Harsh,
I directly downloaded the tar file of Elasticsearch ("elasticsearch-6.7.0.tar.gz") and untar it.
But when i did this i was logged in as a root and untar it as a root.
When i tried to run the ./elasticsearch i was getting error as "elasticsearch cannot run as a root". Then i changed the ownership of the related folders and then ran elasticsearch.


Hi Nidhi,

Please disable the firewalld once and check again that they are able to communicate or not.

Systemctl stop firewalld

This is just for check as i want to know that is it firewall proble or anything else?


$ systemctl stop firewalld
bash: systemctl: command not found

Is port 9300 available as well?

No, for port 9300 connection refused, so it is not available.

This can't work because of this:

transport.host: localhost

Remove this line.

Please don't post unformatted code, logs, or configuration as it's very hard to read.

Instead, paste the text and format it with </> icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

Anyway, here is the problem:

[2020-01-21T09:28:40,384][INFO ][o.e.b.BootstrapChecks ] [master_node] bound or publishing to a non-loopback address, enforcing bootstrap checks
ERROR: [3] bootstrap checks failed
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65535]
[2]: max number of threads [1024] for user [pandeyi] is too low, increase to at least [4096]
[3]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

Please read https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.