Data not indexed into ElasticSearch from RabbitMQ

After proper setting up RabbitMQ river for elasticsearch, I issued the
command GET <my_ip>:9200/_river/my_river/status,

{

"_index": "_river",

"_type": "my_river",

"_id": "_status",

"_version": 2,

"found": true,

"_source": {

    "node": {

        "id": "-nA8mbDEQ4e3l4HVqlIToA",

        "name": "Skullfire",

        "transport_address": "inet[/<my_ip>:9300]"

    }

}

}

but data is shown to be indexed. Please help.

Thank you.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/124cd5c2-3de4-441d-978d-6243eb7fe22d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I'd recommend that you use Logstash with the rabbitmq input instead. Rivers
are being deprecated so fewer people will likely be able to help.

On 17 March 2015 at 10:23, Olalekan Elesin elesin.olalekan@gmail.com
wrote:

After proper setting up RabbitMQ river for elasticsearch, I issued the
command GET <my_ip>:9200/_river/my_river/status,

{

"_index": "_river",

"_type": "my_river",

"_id": "_status",

"_version": 2,

"found": true,

"_source": {

    "node": {

        "id": "-nA8mbDEQ4e3l4HVqlIToA",

        "name": "Skullfire",

        "transport_address": "inet[/<my_ip>:9300]"

    }

}

}

but data is shown to be indexed. Please help.

Thank you.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/124cd5c2-3de4-441d-978d-6243eb7fe22d%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/124cd5c2-3de4-441d-978d-6243eb7fe22d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X_Lvi5%2BfZmxBB%2B_ALNn0jMMoiw_RV38QMp5y9JkHrfSkg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Thanks Mark. I have gone through the Logstash documentation on RabbitMQ.
Do you have an idea of how I can stream the logs in realtime using any
programming language?

On Tuesday, March 17, 2015 at 6:23:02 PM UTC+1, Olalekan Elesin wrote:

After proper setting up RabbitMQ river for elasticsearch, I issued the
command GET <my_ip>:9200/_river/my_river/status,

{

"_index": "_river",

"_type": "my_river",

"_id": "_status",

"_version": 2,

"found": true,

"_source": {

    "node": {

        "id": "-nA8mbDEQ4e3l4HVqlIToA",

        "name": "Skullfire",

        "transport_address": "inet[/<my_ip>:9300]"

    }

}

}

but data is shown to be indexed. Please help.

Thank you.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d6263d54-7ebc-4159-b362-1e3318d54779%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Not directly sorry.

Though you can find info about the official clients here -
http://www.elastic.co/guide/

On 18 March 2015 at 01:58, Olalekan Elesin elesin.olalekan@gmail.com
wrote:

Thanks Mark. I have gone through the Logstash documentation on RabbitMQ.
Do you have an idea of how I can stream the logs in realtime using any
programming language?

On Tuesday, March 17, 2015 at 6:23:02 PM UTC+1, Olalekan Elesin wrote:

After proper setting up RabbitMQ river for elasticsearch, I issued the
command GET <my_ip>:9200/_river/my_river/status,

{

"_index": "_river",

"_type": "my_river",

"_id": "_status",

"_version": 2,

"found": true,

"_source": {

    "node": {

        "id": "-nA8mbDEQ4e3l4HVqlIToA",

        "name": "Skullfire",

        "transport_address": "inet[/<my_ip>:9300]"

    }

}

}

but data is shown to be indexed. Please help.

Thank you.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d6263d54-7ebc-4159-b362-1e3318d54779%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d6263d54-7ebc-4159-b362-1e3318d54779%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X_EUL_r5LkmB-1Uvtq9L8yeaCKgt6o%3D2%3D6rE6zwW1brGA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.