Data type unsigned long is not showing up as an option in index patterns

Hello Team,

In Elastic version 7.11, you have added the support for a new Numeric Data type called unsigned long but when I try to set the index template I don't see that option in the drop-down and also I tried to set it up through the JSON doc. I get an error saying can't add that field into the template. Can you please advise on what I am doing wrong?

Thanks and Regards,
Guru

For me it works in Kibana Index Template Management when setting the type in the Dropdown to other and use unsigned_long in the text box.

1 Like

hey, thanks for your suggestion but I also ran into another issue where I am not able to LOAD JSON with the type as "unsigned_long".

  "unique_id": {
    "coerce": true,
    "index": true,
    "ignore_malformed": false,
    "store": false,
    "type": "unsigned_long",
    "doc_values": true
  },

and also the document should be updated to say that unsigned_long is not part of the drop-down
Numeric field types | Elasticsearch Reference [7.11] | Elastic. Just a suggestion :slight_smile: