Data Visualizer won't accept dd/mm/yyyy format when importing data

I'm trying to import the films.csv file in Data Visualizer and it gives me a 'date_time_exception' error.
Trying to import the data by 'Apply override settings' link it just does not accept the format, 'dd/mm/yyyy''
How do I import the date.
I'm using KIbana version v 7.10.1

mm is for minutes. You probably want MM for months.

Yes,
I did try MM and even MMM; no luck

can you provide the first few lines of films.csv for reference so we can see?

Please find as below:
name,directed_by,genre,id,initial_release_date
0.45,Gary Lennon,Black comedy|Thriller|Psychological thriller|Indie film|Action Film|Crime Thriller|Crime Fiction|Drama,/en/45_2006,30/11/2006
9,Shane Acker,Computer Animation|Animation|Apocalyptic and post-apocalyptic fiction|Science Fiction|Short Film|Thriller|Fantasy,/en/9_2005,21/04/2005

I just tried your file using the latest master branch code and it worked fine:

The date format was automatically detected as dd/MM/yyyy. The overrides page shows it, but I didn't have to type this in as it was automatically detected:

Can you provide some screenshots of the problems you're seeing? Maybe it's nothing to do with the date format but something else?

Also, you didn't say which version you were using. Really old versions of the file data visualizer had some bugs that you could be hitting. (But really really old versions of the data visualizer didn't support custom date format overrides at all, so I guess you're not using one of those.)