Date calculation does not work in DELETE


(Norbert Hartl) #1

Hi,

I'm trying to delete entries in my indexes that are older than 6 months.
I'm using the curl command

curl -vv -XDELETE http://localhost:9200/myindex/_query -d @delete-old.json
delete-old.json content:

{

"query" : {

  "filtered" : {

     "query" : {

        "match_all" : { }

     },

     "filter" : {

        "range" : {

           "timeStamp" : {

              "lte" : "now-6M"

           }

        }

     }

  }

}

}

The query does work when doing a search. It does also work if I use

"timeStamp" : {

   "lte" : "2013-09-01T00:00:00+00:00"

}

So is the date calculation "now-6M" not supposed to work in DELETEs?

thanks,

norbert

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ec13a845-aedd-4eb4-b9ca-60eb67c5b773%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Norbert Hartl) #2

btw. I forgot to add I'm using elasticsearch 1.0.1

Norbert

Am 22.03.2014 um 17:28 schrieb Norbert Hartl norbert.hartl@googlemail.com:

Hi,

I'm trying to delete entries in my indexes that are older than 6 months. I'm using the curl command

curl -vv -XDELETE http://localhost:9200/myindex/_query -d @delete-old.json

delete-old.json content:

{

"query" : {

  "filtered" : {

     "query" : {

        "match_all" : { }

     },

     "filter" : {

        "range" : {

           "timeStamp" : {

              "lte" : "now-6M"

           }

        }

     }

  }

}

}

The query does work when doing a search. It does also work if I use

"timeStamp" : {

   "lte" : "2013-09-01T00:00:00+00:00"

}

So is the date calculation "now-6M" not supposed to work in DELETEs?

thanks,

norbert

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ec13a845-aedd-4eb4-b9ca-60eb67c5b773%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/A583FCC2-C912-4DC5-ABDD-C2540CBAFA28%40googlemail.com.
For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #3

Hi Norbert,

This looks like a bug. Will dig deeper and get back to you.

Cheers,
Boaz

On Sunday, March 23, 2014 7:16:24 PM UTC+1, Norbert Hartl wrote:

btw. I forgot to add I’m using elasticsearch 1.0.1

Norbert

Am 22.03.2014 um 17:28 schrieb Norbert Hartl <norber...@googlemail.com<javascript:>

:

Hi,

I'm trying to delete entries in my indexes that are older than 6 months.
I'm using the curl command

curl -vv -XDELETE http://localhost:9200/myindex/_query -d
@delete-old.json
delete-old.json content:

{

"query" : {

  "filtered" : {

     "query" : {

        "match_all" : { }

     },

     "filter" : {

        "range" : {

           "timeStamp" : {

              "lte" : "now-6M"

           }

        }

     }

  }

}

}

The query does work when doing a search. It does also work if I use

"timeStamp" : {

   "lte" : "2013-09-01T00:00:00+00:00"

}

So is the date calculation "now-6M" not supposed to work in DELETEs?

thanks,

norbert

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ec13a845-aedd-4eb4-b9ca-60eb67c5b773%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ec13a845-aedd-4eb4-b9ca-60eb67c5b773%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bd65a11e-5dba-4d5d-842e-8c68db0ddd61%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Boaz Leskes) #4

Heya,

I've added a pull request to fix this
issue: https://github.com/elasticsearch/elasticsearch/pull/5540

You can watch to see when it gets merged in.

Thx for reporting!

Boaz

On Tuesday, March 25, 2014 4:08:50 PM UTC+1, Boaz Leskes wrote:

Hi Norbert,

This looks like a bug. Will dig deeper and get back to you.

Cheers,
Boaz

On Sunday, March 23, 2014 7:16:24 PM UTC+1, Norbert Hartl wrote:

btw. I forgot to add I’m using elasticsearch 1.0.1

Norbert

Am 22.03.2014 um 17:28 schrieb Norbert Hartl norber...@googlemail.com:

Hi,

I'm trying to delete entries in my indexes that are older than 6 months.
I'm using the curl command

curl -vv -XDELETE http://localhost:9200/myindex/_query -d
@delete-old.json
delete-old.json content:

{

"query" : {

  "filtered" : {

     "query" : {

        "match_all" : { }

     },

     "filter" : {

        "range" : {

           "timeStamp" : {

              "lte" : "now-6M"

           }

        }

     }

  }

}

}

The query does work when doing a search. It does also work if I use

"timeStamp" : {

   "lte" : "2013-09-01T00:00:00+00:00"

}

So is the date calculation "now-6M" not supposed to work in DELETEs?

thanks,

norbert

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ec13a845-aedd-4eb4-b9ca-60eb67c5b773%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ec13a845-aedd-4eb4-b9ca-60eb67c5b773%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/403e2c48-f9f6-46e8-b370-fe024943b02b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Norbert Hartl) #5

Am 26.03.2014 um 09:52 schrieb Boaz Leskes b.leskes@gmail.com:

Heya,

I've added a pull request to fix this issue: https://github.com/elasticsearch/elasticsearch/pull/5540

You can watch to see when it gets merged in.

Thx for reporting!

Thank you very much for fixing it.

Norbert

Boaz

On Tuesday, March 25, 2014 4:08:50 PM UTC+1, Boaz Leskes wrote:
Hi Norbert,

This looks like a bug. Will dig deeper and get back to you.

Cheers,
Boaz

On Sunday, March 23, 2014 7:16:24 PM UTC+1, Norbert Hartl wrote:
btw. I forgot to add I'm using elasticsearch 1.0.1

Norbert

Am 22.03.2014 um 17:28 schrieb Norbert Hartl norber...@googlemail.com:

Hi,

I'm trying to delete entries in my indexes that are older than 6 months. I'm using the curl command

curl -vv -XDELETE http://localhost:9200/myindex/_query -d @delete-old.json

delete-old.json content:

{

"query" : {

  "filtered" : {

     "query" : {

        "match_all" : { }

     },

     "filter" : {

        "range" : {

           "timeStamp" : {

              "lte" : "now-6M"

           }

        }

     }

  }

}

}

The query does work when doing a search. It does also work if I use

"timeStamp" : {

   "lte" : "2013-09-01T00:00:00+00:00"

}

So is the date calculation "now-6M" not supposed to work in DELETEs?

thanks,

norbert

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ec13a845-aedd-4eb4-b9ca-60eb67c5b773%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/403e2c48-f9f6-46e8-b370-fe024943b02b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/C97DC526-F488-45F4-8BA5-C0D23987747A%40googlemail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6