date_histogram rounding and minimum_number_should_match in filter not working


(Sorostaran) #1

Recently moved two indexes from our 18.7 cluster to our 19.3 cluster and date_histogram with rounding such as "day:ceiling" no longer works.

{
"size": 0,
"query": {
"match_all": { }
},
"facets": {
"uts": {
"date_histogram": {
"field": "uts",
"interval": "day:ceiling"
}
}
}
}

This works fine on our 18.7 cluster, but on our 19.3 cluster, we get

NumberFormatException[For input string: "day:ceiling"]

We get the same error on our 19.7 cluster. Without the rounding (just "day" etc.) it works on both clusters.


Another issue we had with the index transfer was specifying minimum_number_should_match in a bool filter, it works fine on our 18.7 cluster, but gives an error on our 19.3 cluster. The setting works fine in a bool query on both clusters.

Help on this would be much appreciated.


(system) #2