date_histogram rounding and minimum_number_should_match in filter not working


(Sorostaran) #1

We recently moved two indexes from our 0.18.7 cluster to our 0.19.3 cluster
and
date_histogram with rounding such as "day:ceiling" no longer works.

{
"size": 0,
"query": {
"match_all": { }
},
"facets": {
"uts": {
"date_histogram": {
"field": "uts",
"interval": "day:ceiling"
}
}
}
}

This works fine on our 0.18.7 cluster, but on our 0.19.3 cluster, we get

NumberFormatException[For input string: "day:ceiling"]

We tested this on a different index on our 0.19.8 cluster and got the same
error. Without the rounding (just "day"
etc.) it works on all three clusters.


Another issue we had with the index transfer was specifying
minimum_number_should_match in a bool filter, it works fine on our 0.18.7
cluster, but gives an error on our 0.19.3 cluster. The setting works fine
in a
bool query on both clusters.

Help on this would be appreciated.


(Mike) #2

I'm getting the same issue with .19.8.

date_histogram : {
"field" : "date",
"interval" : "day"
}

Works ok, but chaning it to

date_histogram : {
"field" : "date",
"interval" : "day:ceiling"
}
Fails with ElasticSearchParseException[Failed to parse [day:ceiling]];

On Wednesday, July 18, 2012 12:59:51 PM UTC-4, Sorostaran wrote:

We recently moved two indexes from our 0.18.7 cluster to our 0.19.3
cluster and
date_histogram with rounding such as "day:ceiling" no longer works.

{
"size": 0,
"query": {
"match_all": { }
},
"facets": {
"uts": {
"date_histogram": {
"field": "uts",
"interval": "day:ceiling"
}
}
}
}

This works fine on our 0.18.7 cluster, but on our 0.19.3 cluster, we get

NumberFormatException[For input string: "day:ceiling"]

We tested this on a different index on our 0.19.8 cluster and got the same
error. Without the rounding (just "day"
etc.) it works on all three clusters.


Another issue we had with the index transfer was specifying
minimum_number_should_match in a bool filter, it works fine on our 0.18.7
cluster, but gives an error on our 0.19.3 cluster. The setting works fine
in a
bool query on both clusters.

Help on this would be appreciated.

--


(Shay Banon) #3

Part of the work done in 0.19 to improve the date histogram behavior removed the option to specify the rounding method (and defaults to floor). Other values didn't make much sense to be honest, but if they do for you, would love to know. I will fix the docs to reflect the fact that its no longer available.

On Jul 18, 2012, at 6:59 PM, Sorostaran steven@datafeedfile.com wrote:

We recently moved two indexes from our 0.18.7 cluster to our 0.19.3 cluster and
date_histogram with rounding such as "day:ceiling" no longer works.

{
"size": 0,
"query": {
"match_all": { }
},
"facets": {
"uts": {
"date_histogram": {
"field": "uts",
"interval": "day:ceiling"
}
}
}
}

This works fine on our 0.18.7 cluster, but on our 0.19.3 cluster, we get

NumberFormatException[For input string: "day:ceiling"]

We tested this on a different index on our 0.19.8 cluster and got the same error. Without the rounding (just "day"
etc.) it works on all three clusters.


Another issue we had with the index transfer was specifying
minimum_number_should_match in a bool filter, it works fine on our 0.18.7
cluster, but gives an error on our 0.19.3 cluster. The setting works fine in a
bool query on both clusters.

Help on this would be appreciated.

--


(Mike) #4

Thanks for the reply. I only tested it out to see how my results would
change, so I didn't have a specific need for it.

--


(system) #5