Date Range filter in data table Kibana 5.4.1


(Louie Hernandez) #1

I have a column in my data table type date, and I want to be able to query said column. When I try to press the magnifying glass "filter value" Kibana gives me an error.

I guess what I am trying to ask is how do I create a date range filter for my data table?


(Felix Stürmer) #2

Hi @Louie_Hernandez,

could you let me know which version of Kibana you are using and what the error message is? A screenshot of the problem could be helpful too. Thank you!


(Louie Hernandez) #3

Hey! @weltenwort

I am using Kibana version 5.4.1
It's not so much that I am getting an error message, but more so that i am trying to filter my data table with what's in my booked date or active date column. I am also wondering if there is a way to filter it with the timepicker on the top right of the screen. Or will I have to create a custom plugin to do that?

setup2

Regards,

Lou


(Felix Stürmer) #4

The timepicker in the top left currently only filters by the primary time field configured for the index pattern. There are several other ways you could use to filter your results:

  • You can enter range queries for any field into the query bar above the dashboard, e.g. BookedDate:[2015-01-01 TO 2015-01-20].
  • You can click the :mag: icons to the add filters for that specific date to the filter bar. You mentioned this does not work for you?
  • Starting with Kibana 5.5.0, there is a new filter editor interface, which allows you to define range filters on fields:

(Louie Hernandez) #5

hey @weltenwort
thanks for the response. Thanks your responses helped out a lot, I was not writing the range queries correctly. Also, just as an option, how do you configure a primary time field for an index pattern?


(Felix Stürmer) #6

When creating an index pattern in the management section, you can select one of the date type fields as the primary time field:


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.