Debian installation error


(Jimmy Sand) #1

Hi!
I'm trying to install Logstash from online repository. Source added and key added too.
Successfully downloaded and unpacked.
When setup tries to set up logstash there many errors. I already spend 2 days for diggin it - no answers.
Any help any suggestions?

Debian 8.7

:~$ java -version
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

sudo apt-get install logstash
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  logstash
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/95.3 MB of archives.
After this operation, 175 MB of additional disk space will be used.
Selecting previously unselected package logstash.
(Reading database ... 43711 files and directories currently installed.)
Preparing to unpack .../logstash_1%3a5.1.2-1_all.deb ...
Unpacking logstash (1:5.1.2-1) ...
Setting up logstash (1:5.1.2-1) ...
sed: can't read /etc/logstash/logstash.yml: No such file or directory
/etc/logstash/startup.options is not a file path
Errno::EISDIR: Is a directory - /etc/default/
          write at org/jruby/RubyIO.java:4058
          write at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/pleaserun-0.0.27/lib/pleaserun/installer.rb:32
  install_files at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/pleaserun-0.0.27/lib/pleaserun/installer.rb:23
           call at org/jruby/RubyProc.java:281
          yield at org/jruby/RubyYielder.java:81
          files at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/pleaserun-0.0.27/lib/pleaserun/platform/systemd.rb:24
           call at org/jruby/RubyProc.java:281
           each at file:/usr/share/logstash/vendor/jruby/lib/jruby.jar!/jruby/kernel/jruby/generator.rb:246
  install_files at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/pleaserun-0.0.27/lib/pleaserun/installer.rb:18
      run_human at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/pleaserun-0.0.27/lib/pleaserun/cli.rb:174
        execute at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/pleaserun-0.0.27/lib/pleaserun/cli.rb:130
            run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
            run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132
         (root) at /usr/share/logstash/lib/systeminstall/pleasewrap.rb:12
{:timestamp=>"2017-01-23T10:28:14.019000+0500", :message=>"No platform selected. Autodetecting...", :platform=>"systemd", :version=>"215", :level=>:warn}
{:timestamp=>"2017-01-23T10:28:14.062000+0500", :message=>"Writing file", :destination=>"/etc/default/"}
Unable to install system startup script for Logstash.

(Aaron Mildenstein) #2

You have something very unusual going on in your system, as Logstash installs just fine for me on Debian and Ubuntu.

sed: can't read /etc/logstash/logstash.yml: No such file or directory
/etc/logstash/startup.options is not a file path

These lines indicate that the package did not install any files. The files were simply not found. I don't know if it was improperly downloaded or cached, or what, but it's certainly not working.


(Jimmy Sand) #3

problem was in write access for some folders running under sudo.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.