Debian packages unreachable


(me-2) #1

I'm unable to install logstash from the debian packages (as described in
http://www.elasticsearch.org/blog/apt-and-yum-repositories/ )

Here is the output of apt-get install:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
logstash
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 76.4 MB of archives.
After this operation, 82.2 MB of additional disk space will be used.
Err http://packages.elasticsearch.org/logstash/1.3/debian/ stable/main
logstash all 1.3.1-1+debian
403 Forbidden
Failed to fetch
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
403 Forbidden
E: Unable to fetch some archives, maybe run apt-get update or try with
--fix-missing?

Navigating directly to
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
also results in the same error (S3 I believe):

<?xml version="1.0" encoding="UTF-8"?>AccessDenied

Access DeniedA842E730DF4F32E6
WQZkc+CmZShNDGnc1wgB4H7nwqmmxcp4EybuJTNmayrObiqg1vLsgI0KymuRFlW4

I added the following lines to /etc/apt/sources.list:

elasticsearch and logstash

deb http://packages.elasticsearch.org/elasticsearch/1.0/debian stable main
deb http://packages.elasticsearch.org/logstash/1.3/debian stable main

Stephen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f1134fc9-3ef6-46cd-83c8-032a41dfdd4a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Richard Pijnenburg) #2

Hi Stephen,

We found an issue with the S3 hosting when files have a + sign in the filename.
For some reason it doesn't get encoded/decoded correctly somewhere. ( S3 side most likely )
We are looking for a better solution right now.
Will update the thread when we've solved it.

Cheers

Richard

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a3331f7d-9423-4e49-8a42-00e7099d3a33%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Richard Pijnenburg) #3

Sorry i haven't updated this thread.
Its been solved in the meantime :slight_smile:

On Monday, December 30, 2013 8:47:17 AM UTC, Richard Pijnenburg wrote:

Hi Stephen,

We found an issue with the S3 hosting when files have a + sign in the
filename.
For some reason it doesn't get encoded/decoded correctly somewhere. ( S3
side most likely )
We are looking for a better solution right now.
Will update the thread when we've solved it.

Cheers

Richard

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f4862a3a-9868-4841-b359-afc7cc1714df%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4